summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFichteFoll2019-04-02 14:17:54 +0200
committerFichteFoll2019-04-02 14:17:54 +0200
commit22600e47d5a79fc427bf1afdfd7ad2c963dd7558 (patch)
treec0b12742f9df9563d0fcdb903c97a180fe94b1b8
downloadaur-22600e47d5a79fc427bf1afdfd7ad2c963dd7558.tar.gz
First release
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12fa9a437b14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = aegisub-yutils
+ pkgdesc = Yutils library for the Aegisub Automation interface
+ pkgver = v2015.01.17
+ pkgrel = 1
+ url = https://github.com/Youka/Yutils
+ arch = i686
+ arch = x86_64
+ depends = aegisub
+ source = Yutils-v2015.01.17.lua::https://github.com/Youka/Yutils/raw/T1/src/Yutils.lua
+ sha256sums = 45c199bf3e4897a0fca5dfc21a7e53da14ea9ee757c7d919145cab2324200a39
+
+pkgname = aegisub-yutils
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5322e87ab215
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src/
+pkg/
+*.tar.gz
+*.pkg.tar.xz
+*.log
+Yutils*.lua
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bd32f103d8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: FichteFoll <fichtefoll2@googlemail.com>
+
+pkgname=aegisub-yutils
+pkgver=v2015.01.17
+pkgrel=1
+pkgdesc="Yutils library for the Aegisub Automation interface"
+arch=('i686' 'x86_64')
+url="https://github.com/Youka/Yutils"
+license=('')
+depends=('aegisub')
+
+# https://github.com/Youka/Yutils/raw/T1/src/Yutils.lua
+source=("Yutils-${pkgver}.lua::https://github.com/Youka/Yutils/raw/T1/src/Yutils.lua")
+sha256sums=('45c199bf3e4897a0fca5dfc21a7e53da14ea9ee757c7d919145cab2324200a39')
+
+
+package() {
+ local prefix="/usr/share/aegisub/automation"
+
+ install -D -m644 "Yutils-${pkgver}.lua" "${pkgdir}${prefix}/include/Yutils.lua"
+}