summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Semjonov2018-11-29 09:50:57 +0100
committerAnton Semjonov2018-11-29 09:50:57 +0100
commitc4ccb8bca9f8f3e28bc92bdd25b476fabf32aee9 (patch)
treefa244586bf9031506b0564963b04cd7bee58559f
downloadaur-c4ccb8bca9f8f3e28bc92bdd25b476fabf32aee9.tar.gz
first aur package for 0.5.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..783a789d0c37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aenker
+ pkgdesc = Authenticated encryption on the commandline using a chunked construction and elliptic curve keys.
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/ansemjo/aenker
+ arch = any
+ license = MIT
+ makedepends = go
+ provides = aenker
+ conflicts = aenker
+ source = aenker-0.5.2.tar.gz::https://github.com/ansemjo/aenker/archive/0.5.2.tar.gz
+ sha256sums = 55ae760af8f2cc4cc3e780e7db692e6957ff341f0076919cf4dae3170664512c
+
+pkgname = aenker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c958165288b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Anton Semjonov < a**** \ät semjonov.de >
+
+pkgname="aenker"
+pkgdesc="Authenticated encryption on the commandline using a chunked construction and elliptic curve keys."
+
+pkgver=0.5.2
+pkgrel=1
+
+arch=('any')
+url="https://github.com/ansemjo/$pkgname"
+license=('MIT')
+
+depends=()
+makedepends=('go')
+
+provides=($pkgname)
+conflicts=($pkgname)
+
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('55ae760af8f2cc4cc3e780e7db692e6957ff341f0076919cf4dae3170664512c')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make "$pkgname"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# -------------------------------
+