summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2018-02-05 14:44:48 +0700
committerKonstantin Shalygin2018-02-05 14:44:48 +0700
commit3f9f8ebb7a0b99961556670118379e5c3e9a15d2 (patch)
treed75a202a3a5976d7522fcdce1e8ac1b78f55c102
downloadaur-3f9f8ebb7a0b99961556670118379e5c3e9a15d2.tar.gz
First release of aeon.
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD43
-rw-r--r--aeon.sysusers1
-rw-r--r--aeon.tmpfiles1
-rw-r--r--aeond.service14
6 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7057aa84f951
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Feb 5 07:38:00 UTC 2018
+pkgbase = aeon
+ pkgdesc = A lightweight CryptoNote digital currency.
+ pkgver = 0.9.14.0
+ pkgrel = 1
+ url = https://github.com/aeonix/aeon
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = custom:Cryptonote
+ makedepends = boost-libs
+ source = aeond.service
+ source = aeon.sysusers
+ source = aeon.tmpfiles
+ source = https://github.com/aeonix/aeon/archive/v0.9.14.0.tar.gz
+ sha256sums = 6c3cbbe52f86e9c4c423a89938835a8dcec92ce5d9243744bda1ec18faa21924
+ sha256sums = a0cdf75b86073829f4033e367f36e9418dc20556e7adfa6ffac8653c67cd6337
+ sha256sums = 6e9858948c25510f0a30cd179db494d18b32d428183f6679cb7be8ff479aae21
+ sha256sums = 50379f3dfb85fdcf62a92f63fef2a4afc51efdba6a62cf4693a02621b596b8ba
+
+pkgname = aeon
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7c6927b4669a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/*
+src/*
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b21eb69cc7f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Konstantin Shalygin <k0ste@k0ste.ru>
+# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
+
+pkgname='aeon'
+pkgver='0.9.14.0'
+pkgrel='1'
+pkgdesc='A lightweight CryptoNote digital currency.'
+arch=('x86_64')
+url="https://github.com/${pkgname}ix/${pkgname}"
+makedepends=('boost-libs')
+license=('custom:Cryptonote')
+arch=('x86_64' 'armv7h' 'aarch64')
+source=("${pkgname}d.service"
+ "${pkgname}.sysusers"
+ "${pkgname}.tmpfiles"
+ "${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('6c3cbbe52f86e9c4c423a89938835a8dcec92ce5d9243744bda1ec18faa21924'
+ 'a0cdf75b86073829f4033e367f36e9418dc20556e7adfa6ffac8653c67cd6337'
+ '6e9858948c25510f0a30cd179db494d18b32d428183f6679cb7be8ff479aae21'
+ '50379f3dfb85fdcf62a92f63fef2a4afc51efdba6a62cf4693a02621b596b8ba')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ mkdir build
+}
+
+build() {
+ cd "${pkgname}-${pkgver}/build"
+ cmake .. \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_C_FLAGS="-fassociative-math" \
+ -DCMAKE_CXX_FLAGS="-fassociative-math" \
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}/build/src"
+ install -Dm775 "${pkgname}d" "${pkgdir}/usr/bin/${pkgname}d"
+ install -Dm775 "simplewallet" "${pkgdir}/usr/bin/${pkgname}-wallet-cli"
+ install -Dm0644 "${srcdir}/${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
+ install -Dm0644 "${srcdir}/${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+ install -Dm644 "${srcdir}/${pkgname}d.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}d.service"
+}
diff --git a/aeon.sysusers b/aeon.sysusers
new file mode 100644
index 000000000000..670aef1dc0cd
--- /dev/null
+++ b/aeon.sysusers
@@ -0,0 +1 @@
+u aeon - - /var/lib/aeon
diff --git a/aeon.tmpfiles b/aeon.tmpfiles
new file mode 100644
index 000000000000..efd1e0043f7a
--- /dev/null
+++ b/aeon.tmpfiles
@@ -0,0 +1 @@
+d /var/lib/aeon 0755 aeon aeon
diff --git a/aeond.service b/aeond.service
new file mode 100644
index 000000000000..435d251f9f2e
--- /dev/null
+++ b/aeond.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Aeon Full Node
+After=network.target
+
+[Service]
+User=aeon
+Group=aeon
+WorkingDirectory=~
+RuntimeDirectory=aeon
+Type=simple
+ExecStart=/usr/bin/aeond --no-console
+
+[Install]
+WantedBy=multi-user.target