summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2018-06-17 15:32:59 +0700
committerKonstantin Shalygin2018-06-17 15:32:59 +0700
commitf2e7b8406ba032baa04950d3e28be4344cfeaeaa (patch)
tree98e913b373d844b76022e16cfe3bee15c536aba8
parent44553e2ac433ba5c64e9020b52c241df25dc6c93 (diff)
downloadaur-f2e7b8406ba032baa04950d3e28be4344cfeaeaa.tar.gz
Bump to 0.12.1.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--aeon-0.12.0.0_gcc8.patch85
3 files changed, 7 insertions, 97 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36f46c548f4d..1f17015140a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu May 31 14:50:28 UTC 2018
+# Sun Jun 17 08:32:42 UTC 2018
pkgbase = aeon
pkgdesc = A lightweight CryptoNote digital currency.
- pkgver = 0.12.0.0
+ pkgver = 0.12.1.1
pkgrel = 1
url = https://github.com/aeonix/aeon
arch = x86_64
@@ -24,14 +24,12 @@ pkgbase = aeon
source = aeon.sysusers
source = aeon.tmpfiles
source = aeond.conf
- source = https://github.com/aeonix/aeon/archive/v0.12.0.0.tar.gz
- source = aeon-0.12.0.0_gcc8.patch
+ source = https://github.com/aeonix/aeon/archive/v0.12.1.1.tar.gz
sha256sums = 5212dff199bb3880191292976cd8278dcdbae64f9c0ab39a9c2a91a4733186c3
sha256sums = a0cdf75b86073829f4033e367f36e9418dc20556e7adfa6ffac8653c67cd6337
sha256sums = 1da20b66d52db4f1c5b3106cf27ee54033650a0e36c5c775b25c9e86e6027be0
sha256sums = 3ef15e3c9e2d146c415f2e483dd10e4ec36f653e4684c254d9f69a5fb699036b
- sha256sums = 61091d6c76417d6c4901dd3583ecd8b40bc651fd2a78ac78093a3f9c0b36c5b1
- sha256sums = cf1733cea4f6a689add1a9300ed81d0a9115f2c1021ac125ee9d083972027770
+ sha256sums = 08d293a79cd620347c57dd3bc956af89eccb0a03144d920ac853ce63eef1fdcb
pkgname = aeon
diff --git a/PKGBUILD b/PKGBUILD
index e4c084b4b076..b3a94f191c8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
pkgname='aeon'
-pkgver='0.12.0.0'
+pkgver='0.12.1.1'
pkgrel='1'
pkgdesc='A lightweight CryptoNote digital currency.'
arch=('x86_64')
@@ -15,14 +15,12 @@ source=("${pkgname}d.service"
"${pkgname}.sysusers"
"${pkgname}.tmpfiles"
"${pkgname}d.conf"
- "${url}/archive/v${pkgver}.tar.gz"
- "aeon-0.12.0.0_gcc8.patch")
+ "${url}/archive/v${pkgver}.tar.gz")
sha256sums=('5212dff199bb3880191292976cd8278dcdbae64f9c0ab39a9c2a91a4733186c3'
'a0cdf75b86073829f4033e367f36e9418dc20556e7adfa6ffac8653c67cd6337'
'1da20b66d52db4f1c5b3106cf27ee54033650a0e36c5c775b25c9e86e6027be0'
'3ef15e3c9e2d146c415f2e483dd10e4ec36f653e4684c254d9f69a5fb699036b'
- '61091d6c76417d6c4901dd3583ecd8b40bc651fd2a78ac78093a3f9c0b36c5b1'
- 'cf1733cea4f6a689add1a9300ed81d0a9115f2c1021ac125ee9d083972027770')
+ '08d293a79cd620347c57dd3bc956af89eccb0a03144d920ac853ce63eef1fdcb')
backup=("etc/${pkgname}d.conf")
prepare() {
@@ -31,7 +29,6 @@ prepare() {
git clone git://github.com/monero-project/unbound.git external/unbound
git -C external/miniupnp checkout monero
git -C external/unbound checkout monero
- patch -p1 -i "${srcdir}/aeon-0.12.0.0_gcc8.patch"
}
build() {
diff --git a/aeon-0.12.0.0_gcc8.patch b/aeon-0.12.0.0_gcc8.patch
deleted file mode 100644
index 7f61f812251a..000000000000
--- a/aeon-0.12.0.0_gcc8.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-diff -Naupr aeon-0.12.0.0_orig/external/rapidjson/document.h aeon-0.12.0.0/external/rapidjson/document.h
---- aeon-0.12.0.0_orig/external/rapidjson/document.h 2018-05-24 15:54:20.000000000 +0700
-+++ aeon-0.12.0.0/external/rapidjson/document.h 2018-05-31 13:38:38.880208263 +0700
-@@ -1936,7 +1936,12 @@ private:
- if (count) {
- GenericValue* e = static_cast<GenericValue*>(allocator.Malloc(count * sizeof(GenericValue)));
- SetElementsPointer(e);
-+RAPIDJSON_DIAG_PUSH
-+#if defined(__GNUC__) && __GNUC__ >= 8
-+RAPIDJSON_DIAG_OFF(class-memaccess) // ignore complains from gcc that no trivial copy constructor exists.
-+#endif
- std::memcpy(e, values, count * sizeof(GenericValue));
-+RAPIDJSON_DIAG_POP
- }
- else
- SetElementsPointer(0);
-@@ -1949,7 +1954,12 @@ private:
- if (count) {
- Member* m = static_cast<Member*>(allocator.Malloc(count * sizeof(Member)));
- SetMembersPointer(m);
-+RAPIDJSON_DIAG_PUSH
-+#if defined(__GNUC__) && __GNUC__ >= 8
-+RAPIDJSON_DIAG_OFF(class-memaccess) // ignore complains from gcc that no trivial copy constructor exists.
-+#endif
- std::memcpy(m, members, count * sizeof(Member));
-+RAPIDJSON_DIAG_POP
- }
- else
- SetMembersPointer(0);
-diff -Naupr aeon-0.12.0.0_orig/src/crypto/chacha.h aeon-0.12.0.0/src/crypto/chacha.h
---- aeon-0.12.0.0_orig/src/crypto/chacha.h 2018-05-24 15:54:20.000000000 +0700
-+++ aeon-0.12.0.0/src/crypto/chacha.h 2018-05-31 13:39:11.727214182 +0700
-@@ -73,14 +73,14 @@ namespace crypto {
- static_assert(sizeof(chacha_key) <= sizeof(hash), "Size of hash must be at least that of chacha_key");
- tools::scrubbed_arr<char, HASH_SIZE> pwd_hash;
- crypto::cn_slow_hash(data, size, pwd_hash.data(), 0/*light*/, 0/*variant*/, 0/*prehashed*/);
-- memcpy(&key, pwd_hash.data(), sizeof(key));
-+ memcpy(&unwrap(key), pwd_hash.data(), sizeof(key));
- }
-
- inline void generate_chacha_key_prehashed(const void *data, size_t size, chacha_key& key) {
- static_assert(sizeof(chacha_key) <= sizeof(hash), "Size of hash must be at least that of chacha_key");
- tools::scrubbed_arr<char, HASH_SIZE> pwd_hash;
- crypto::cn_slow_hash(data, size, pwd_hash.data(), 0/*light*/, 0/*variant*/, 1/*prehashed*/);
-- memcpy(&key, pwd_hash.data(), sizeof(key));
-+ memcpy(&unwrap(key), pwd_hash.data(), sizeof(key));
- }
-
- inline void generate_chacha_key(std::string password, chacha_key& key) {
-diff -Naupr aeon-0.12.0.0_orig/src/cryptonote_basic/account.cpp aeon-0.12.0.0/src/cryptonote_basic/account.cpp
---- aeon-0.12.0.0_orig/src/cryptonote_basic/account.cpp 2018-05-24 15:54:20.000000000 +0700
-+++ aeon-0.12.0.0/src/cryptonote_basic/account.cpp 2018-05-31 13:38:38.880208263 +0700
-@@ -157,7 +157,7 @@ DISABLE_VS_WARNINGS(4244 4345)
- void account_base::create_from_viewkey(const cryptonote::account_public_address& address, const crypto::secret_key& viewkey)
- {
- crypto::secret_key fake;
-- memset(&fake, 0, sizeof(fake));
-+ memset(&unwrap(fake), 0, sizeof(fake));
- create_from_keys(address, fake, viewkey);
- }
- //-----------------------------------------------------------------
-diff -Naupr aeon-0.12.0.0_orig/src/daemon/rpc_command_executor.cpp aeon-0.12.0.0/src/daemon/rpc_command_executor.cpp
---- aeon-0.12.0.0_orig/src/daemon/rpc_command_executor.cpp 2018-05-24 15:54:20.000000000 +0700
-+++ aeon-0.12.0.0/src/daemon/rpc_command_executor.cpp 2018-05-31 13:38:38.880208263 +0700
-@@ -972,7 +972,7 @@ bool t_rpc_command_executor::print_trans
- }
- else
- {
-- memset(&res.pool_stats, 0, sizeof(res.pool_stats));
-+ res.pool_stats = {};
- if (!m_rpc_server->on_get_transaction_pool_stats(req, res, false) || res.status != CORE_RPC_STATUS_OK)
- {
- tools::fail_msg_writer() << make_error(fail_message, res.status);
-diff -Naupr aeon-0.12.0.0_orig/src/rpc/core_rpc_server_commands_defs.h aeon-0.12.0.0/src/rpc/core_rpc_server_commands_defs.h
---- aeon-0.12.0.0_orig/src/rpc/core_rpc_server_commands_defs.h 2018-05-24 15:54:20.000000000 +0700
-+++ aeon-0.12.0.0/src/rpc/core_rpc_server_commands_defs.h 2018-05-31 13:38:38.880208263 +0700
-@@ -1554,6 +1554,8 @@ namespace cryptonote
- std::vector<txpool_histo> histo;
- uint32_t num_double_spends;
-
-+ txpool_stats(): bytes_total(0), bytes_min(0), bytes_max(0), bytes_med(0), fee_total(0), oldest(0), txs_total(0), num_failing(0), num_10m(0), num_not_relayed(0), histo_98pc(0), num_double_spends(0) {}
-+
- BEGIN_KV_SERIALIZE_MAP()
- KV_SERIALIZE(bytes_total)
- KV_SERIALIZE(bytes_min)