summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-27 13:34:53 +0800
committerzxp198210052023-11-27 13:34:53 +0800
commit17854cdf625258cbba062ca3d814f18fc71216ce (patch)
treeca88564756a4331b93fe0a8a2029f083d50cd945
parent281101d04c4f29e19d6e3dced931724c4fe34233 (diff)
downloadaur-17854cdf625258cbba062ca3d814f18fc71216ce.tar.gz
update to 0.2.2-alpha
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 915b8766f82e..e3ad198e8cc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -29,6 +29,8 @@ pkgbase = aero-browser
depends = libxfixes
depends = libxcb
depends = pango
+ depends = python
+ depends = hicolor-icon-theme
provides = aero-browser
conflicts = aero-browser
source = aero-browser-0.2.2_alpha::git+https://github.com/FrostBreker/Aero.git#tag=v0.2.2-alpha
diff --git a/PKGBUILD b/PKGBUILD
index 77738b44c559..8f30afa6bb1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,6 +38,8 @@ depends=(
'libxfixes'
'libxcb'
'pango'
+ 'python'
+ 'hicolor-icon-theme'
)
makedepends=(
'gendesk'
@@ -64,8 +66,11 @@ package() {
_osarch=linux-unpacked
fi
cp -r "${srcdir}/${pkgname}-${pkgver}/dist/${_osarch}/"* "${pkgdir}/opt/${pkgname}"
- ln -sf "/opt/${pkgname}/${_appname}" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/build/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ ln -sf "/opt/${pkgname}/${_appname}" "${pkgdir}/usr/bin/${pkgname}"
+ for _icons in 32x32 64x64 256x256 512x512 1024x1024;do
+ install -Dm644 "${srcdir}/${pkgname}/public/icons/${_icons}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname}.png"
+ done
install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE.MD" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file