summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Sobolevskiy2017-06-28 16:39:14 +0300
committerAlexander Sobolevskiy2017-06-28 16:39:14 +0300
commit25b35d2b24a2f7fd076bd2f7747ac79d70c545d3 (patch)
tree3aed60fdae4553543e428489d10641bb0e6f8d24
downloadaur-25b35d2b24a2f7fd076bd2f7747ac79d70c545d3.tar.gz
Init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD48
-rw-r--r--aerospike-client-c-libuv.install10
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8fb72398b9c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = aerospike-client-c-libuv
+ pkgdesc = The Aerospike C client provides a C interface for interacting with the Aerospike Database.
+ pkgver = 4.1.7
+ pkgrel = 1
+ url = https://github.com/aerospike/aerospike-client-c
+ install = aerospike-client-c-libuv.install
+ arch = any
+ license = Proprietary
+ makedepends = git
+ depends = libuv
+ depends = python2
+
+pkgname = aerospike-client-c-libuv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d5d5ece2445
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Alexander Sobolevkiy <smak.nsk [at] gmail [dot] com>
+# Based on https://github.com/aerospike/aerospike-client-c
+
+pkgname=aerospike-client-c-libuv
+pkgver=4.1.7
+pkgrel=1
+pkgdesc="The Aerospike C client provides a C interface for interacting with the Aerospike Database."
+arch=('any')
+url="https://github.com/aerospike/aerospike-client-c"
+install=aerospike-client-c-libuv.install
+license=('Proprietary')
+depends=('libuv' 'python2')
+makedepends=('git')
+_gitroot="https://github.com/aerospike/aerospike-client-c.git"
+_gitname="aerospike-client-c"
+
+build() {
+ cd ${srcdir}/
+
+ if [[ -d ${srcdir}/${_gitname} ]] ; then
+ rm -rf "${srcdir}/${_gitname}"
+ fi
+
+ git clone --recursive --branch ${pkgver} ${_gitroot}
+
+ cd ${srcdir}/${_gitname}/
+
+ make EVENT_LIB=libuv
+}
+
+package() {
+
+ mkdir -p -m 755 "${pkgdir}/usr/include"
+ mkdir -p -m 755 "${pkgdir}/usr/lib/"
+ mkdir -p -m 755 "${pkgdir}/opt/aerospike/client/sys/udf/lua/"
+ mkdir -p -m 755 "${pkgdir}/opt/aerospike/client/usr/udf/lua/"
+
+ cd ${srcdir}/${_gitname}/
+
+ cp -r target/Linux-x86_64/include/aerospike/ "${pkgdir}/usr/include/"
+ cp -r target/Linux-x86_64/include/citrusleaf/ "${pkgdir}/usr/include/"
+
+ install -Dm644 target/Linux-x86_64/lib/libaerospike.a "${pkgdir}/usr/lib/"
+
+ install -Dm644 modules/lua-core/src/aerospike.lua "${pkgdir}/opt/aerospike/client/sys/udf/lua/"
+ install -Dm644 modules/lua-core/src/as.lua "${pkgdir}/opt/aerospike/client/sys/udf/lua/"
+ install -Dm644 modules/lua-core/src/stream_ops.lua "${pkgdir}/opt/aerospike/client/sys/udf/lua/"
+}
diff --git a/aerospike-client-c-libuv.install b/aerospike-client-c-libuv.install
new file mode 100644
index 000000000000..3a4a8104e50e
--- /dev/null
+++ b/aerospike-client-c-libuv.install
@@ -0,0 +1,10 @@
+post_install(){
+ echo
+ echo ":: Node.js Aerospike client install:"
+ echo "--------------------------------"
+ echo " export PREFIX='/usr'"
+ echo " export AEROSPIKE_LUA_PATH='/opt/aerospike/client/sys/udf/lua'"
+ echo " npm install aerospike"
+ echo "--------------------------------"
+
+}