summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2024-05-20 02:08:04 +0200
committerMichal Wojdyla2024-05-20 02:08:04 +0200
commitb53f01a98da9b32202df6e336fbe929659d987fd (patch)
treecaa9a1c1c5c98ed7e1c7e577fee33d7be083ae00
parent0d660ee519e3727afd71d9f5b340ace131357df1 (diff)
downloadaur-b53f01a98da9b32202df6e336fbe929659d987fd.tar.gz
update to 6.6.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 27 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5609c88e0db..ac7ef72137fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
-# Generated by mksrcinfo v8
-# Út led 8 15:30:57 UTC 2019
pkgbase = aerospike-client-c-libuv
pkgdesc = The Aerospike C client provides a C interface for interacting with the Aerospike Database.
- pkgver = 4.3.20
+ pkgver = 6.6.1
pkgrel = 1
url = https://github.com/aerospike/aerospike-client-c
arch = any
license = apache
makedepends = git
depends = libuv
- depends = python2
+ depends = python
provides = aerospike-client-c
conflicts = aerospike-client-c-libev
conflicts = aerospike-client-c-libevent
+ source = git+https://github.com/aerospike/aerospike-client-c.git#tag=6.6.1
+ source = git+https://github.com/aerospike/aerospike-common
+ source = git+https://github.com/aerospike/aerospike-mod-lua
+ source = git+https://github.com/aerospike/lua.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = aerospike-client-c-libuv
-
diff --git a/PKGBUILD b/PKGBUILD
index 18c35b910b48..b4708edac05e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,35 @@
-# Maintainer: Daniel Milde <daniel@milde.cz>
+# Contributor: Daniel Milde <daniel@milde.cz>
# Based on https://github.com/aerospike/aerospike-client-c
pkgname=aerospike-client-c-libuv
-pkgver=4.3.20
+pkgver=6.6.1
pkgrel=1
pkgdesc="The Aerospike C client provides a C interface for interacting with the Aerospike Database."
arch=('any')
url="https://github.com/aerospike/aerospike-client-c"
license=('apache')
-depends=('libuv' 'python2')
+depends=('libuv' 'python')
makedepends=('git')
provides=('aerospike-client-c')
conflicts=('aerospike-client-c-libev' 'aerospike-client-c-libevent')
_gitroot="https://github.com/aerospike/aerospike-client-c.git"
_gitname="aerospike-client-c"
+source=("git+$_gitroot#tag=$pkgver"
+ "git+https://github.com/aerospike/aerospike-common"
+ "git+https://github.com/aerospike/aerospike-mod-lua"
+ "git+https://github.com/aerospike/lua.git")
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
-build() {
- cd ${srcdir}/
-
- if [[ -d ${srcdir}/${_gitname} ]] ; then
- rm -rf "${srcdir}/${_gitname}"
- fi
-
- git clone --recursive --branch ${pkgver} ${_gitroot}
+prepare() {
+ cd ${srcdir}/${_gitname}/
+ git submodule init
+ git config submodule.modules/common.url "${srcdir}/aerospike-common"
+ git config submodule.modules/mod-lua.url "${srcdir}/aerospike-mod-lua"
+ git config submodule.modules/lua.url "${srcdir}/lua"
+ git submodule--helper update
+}
+build() {
cd ${srcdir}/${_gitname}/
make EVENT_LIB=libuv