summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Milde2017-12-01 17:26:29 +0100
committerDaniel Milde2017-12-01 17:26:55 +0100
commitc6cc6115bbbf3cd3c65bb3506b332760f0019898 (patch)
tree47ee7d1cce31739d12e617df52c1fea9dbfdf3d2
downloadaur-c6cc6115bbbf3cd3c65bb3506b332760f0019898.tar.gz
initial
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
-rw-r--r--aerospike-client-python.patch12
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8918f71fe1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Fri Dec 1 16:25:23 UTC 2017
+pkgbase = aerospike-client-python
+ pkgdesc = Aerospike Client Library for Python
+ pkgver = 2.2.3
+ pkgrel = 1
+ url = https://www.aerospike.com/docs/client/python
+ arch = any
+ license = apache
+ depends = openssl
+ depends = aerospike-client-c-libuv
+ source = https://files.pythonhosted.org/packages/source/a/aerospike/aerospike-2.2.3.tar.gz
+ source = aerospike-client-python.patch
+ sha512sums = 9ed191d2f7b146c3aa4817ed1314bc1d8e76ae484948724da1d1b020a84f787284dadc1067a58c04f3122ff6d70a06b39596a8c3ca5062ae5aa955013d082942
+ sha512sums = c30d53471e2fc684b8e4ef5095108e82b60a83f162f19d46cb148f506b20061fa2bfaf07a5112ce4e4c502b705fafaafc9da8cd15befcb615c5b76a04d19bc70
+
+pkgname = aerospike-client-python
+ depends = python
+ depends = python-setuptools
+
+pkgname = aerospike-client-python2
+ depends = python2
+ depends = python2-setuptools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec877fa2f970
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+pkgname=aerospike-client-python
+pkgbase='aerospike-client-python'
+pkgname=(aerospike-client-python aerospike-client-python2)
+_name=aerospike
+pkgver=2.2.3
+pkgrel=1
+pkgdesc="Aerospike Client Library for Python"
+license=('apache')
+arch=('any')
+url="https://www.aerospike.com/docs/client/python"
+depends=('openssl' 'aerospike-client-c-libuv')
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz
+ $pkgbase.patch)
+sha512sums=('9ed191d2f7b146c3aa4817ed1314bc1d8e76ae484948724da1d1b020a84f787284dadc1067a58c04f3122ff6d70a06b39596a8c3ca5062ae5aa955013d082942'
+ 'c30d53471e2fc684b8e4ef5095108e82b60a83f162f19d46cb148f506b20061fa2bfaf07a5112ce4e4c502b705fafaafc9da8cd15befcb615c5b76a04d19bc70')
+
+prepare() {
+ cd "${srcdir}/aerospike-${pkgver}"
+ patch -Np1 -i "${srcdir}/${pkgbase}.patch"
+}
+
+build_aerospike-client-python() {
+ export DOWNLOAD_C_CLIENT=0
+ cd "${srcdir}/aerospike-${pkgver}"
+ python setup.py build
+}
+
+build_aerospike-client-python2() {
+ export DOWNLOAD_C_CLIENT=0
+ cd "${srcdir}/aerospike-${pkgver}"
+ python2 setup.py build
+}
+
+package_aerospike-client-python() {
+ depends=('python' 'python-setuptools')
+ cd "${srcdir}/aerospike-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ rm -r "${pkgdir}/usr/aerospike"
+}
+
+package_aerospike-client-python2() {
+ depends=('python2' 'python2-setuptools')
+ cd "${srcdir}/aerospike-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ rm -r "${pkgdir}/usr/aerospike"
+}
diff --git a/aerospike-client-python.patch b/aerospike-client-python.patch
new file mode 100644
index 000000000000..52386040a869
--- /dev/null
+++ b/aerospike-client-python.patch
@@ -0,0 +1,12 @@
+diff -ura aerospike-2.2.3/setup.py aerospike-2.2.3-new/setup.py
+--- aerospike-2.2.3/setup.py 2017-10-11 00:29:24.000000000 +0200
++++ aerospike-2.2.3-new/setup.py 2017-12-01 17:16:32.561130177 +0100
+@@ -202,7 +202,7 @@
+ '-rdynamic', '-finline-functions',
+ '-DMARCH_x86_64'
+ ]
+- libraries = libraries + ['rt']
++ libraries = libraries + ['rt', 'uv']
+ if AEROSPIKE_C_HOME:
+ PREFIX = AEROSPIKE_C_HOME + '/target/Linux-x86_64'
+ else: