summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-11-22 21:01:54 +0100
committerPiotr Rogoża2015-11-22 21:01:54 +0100
commitbf8256d0a58ca42a4cd8888aae918ec4f76d0067 (patch)
tree03c7f5eddcbde5ec6252f4cb0c5cbc578ee89733
downloadaur-bf8256d0a58ca42a4cd8888aae918ec4f76d0067.tar.gz
Initial commit, version 1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02194090b0b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aeskeyfind
+ pkgdesc = automatic techniques for locating 128-bit and 256-bit AES keys in a captured memory image
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://citp.princeton.edu/research/memory/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = https://citp.princeton.edu/memory-content/src/aeskeyfind-1.0.tar.gz
+ sha256sums = 1417e5c1b61e86bb9527db1f5bee1995a0eea82475db3cbc880e04bf706083e4
+ sha256sums = SKIP
+
+pkgname = aeskeyfind
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7542111cec2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public@gmail.com>
+
+pkgname=aeskeyfind
+pkgver=1.0
+pkgrel=1
+pkgdesc='automatic techniques for locating 128-bit and 256-bit AES keys in a captured memory image'
+arch=('i686' 'x86_64')
+url='https://citp.princeton.edu/research/memory/'
+license=('GPL')
+depends=(glibc)
+makedepends=()
+source=(https://citp.princeton.edu/memory-content/src/$pkgname-$pkgver.tar.gz)
+sha256sums=('1417e5c1b61e86bb9527db1f5bee1995a0eea82475db3cbc880e04bf706083e4'
+ 'SKIP')
+build(){
+ cd "$srcdir"/$pkgname
+ make
+}
+package(){
+ cd "$srcdir"/$pkgname
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}