summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-04-21 19:35:15 +0200
committerhaawda2018-04-21 19:35:15 +0200
commitf5eb310d09fefeac2e6e250911161f82f9481b75 (patch)
tree76d1a0082c841358489357e86d4ceb6d23120095
downloadaur-f5eb310d09fefeac2e6e250911161f82f9481b75.tar.gz
initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae5cdcf4ab4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = aeskulap
+ pkgdesc = Medical image viewer and DICOM client. Compatible with parallel installation of the package 'dcmtk'.
+ pkgver = 0.2.2.beta2
+ pkgrel = 1
+ url = http://www.nongnu.org/aeskulap
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = perl-xml-parser
+ depends = libglademm
+ depends = dconf
+ depends = dcmtk
+ options = !libtool
+ source = aeskulap-0.2.2.beta2.tar.gz::https://github.com/jenslody/aeskulap/archive/release-0-2-2-beta2.tar.gz
+ md5sums = fe440e2a266a1434cb74f3c90838a596
+
+pkgname = aeskulap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18080ef521ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Tomáš Mládek < tmladek {} inventati dt org >
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=aeskulap
+pkgver=0.2.2.beta2
+pkgrel=1
+pkgdesc="Medical image viewer and DICOM client. Compatible with parallel installation of the package 'dcmtk'."
+arch=('i686' 'x86_64')
+url="http://www.nongnu.org/aeskulap"
+license=('GPL')
+depends=('libglademm' 'dconf' 'dcmtk')
+makedepends=('perl-xml-parser')
+options=('!libtool')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jenslody/aeskulap/archive/release-0-2-2-beta2.tar.gz")
+md5sums=('fe440e2a266a1434cb74f3c90838a596')
+
+build() {
+ cd $pkgname-release-${pkgver//./-}
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --with-gconf-schema-file-dir=/usr/share/gconf/schemas
+ make
+}
+
+package() {
+ cd $pkgname-release-${pkgver//./-}
+ make DESTDIR="${pkgdir}" install
+}