summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRootyjr2019-07-07 22:17:23 -0500
committerRootyjr2019-07-07 22:17:23 -0500
commit7ebb192f5174bcf5e700756b75dae4246adc0e5b (patch)
tree39f1dc3c94ba2a1eb04670bb7f23a7ceb67fc490
downloadaur-7ebb192f5174bcf5e700756b75dae4246adc0e5b.tar.gz
Upload first copy of aespresso
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49e63c8fce3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = aespresso
+ pkgdesc = A Gtk3 frontend for archlinux's archlinux-java script.
+ pkgver = 0.1.0
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/Rootyjr/aespresso/releases
+ arch = x86_64
+ license = custom:BSD
+ makedepends = rust
+ depends = gtk3
+ depends = lxqt-sudo
+ source = aespresso-0.1.0.tar.gz::https://github.com/Rootyjr/aespresso/archive/v0.1.0.tar.gz
+ md5sums = d7acd650bf4930946eb679c7b7330126
+
+pkgname = aespresso
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1de71a2258bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Rootyjr <rooty (a+) kwtechllc (dot) com>
+pkgname=aespresso
+pkgver=0.1.0
+pkgrel=1
+epoch=0
+pkgdesc="A Gtk3 frontend for archlinux's archlinux-java script."
+arch=('x86_64')
+url="https://github.com/Rootyjr/$pkgname/releases"
+license=('custom:BSD')
+depends=('gtk3' 'lxqt-sudo')
+makedepends=('rust')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Rootyjr/$pkgname/archive/v${pkgver}.tar.gz")
+md5sums=('d7acd650bf4930946eb679c7b7330126')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --bin aespresso --target-dir .
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ cd release
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ cd ..
+ install -Dm644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}