summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Barroso2015-06-15 21:26:00 +0200
committerJorge Barroso2015-06-15 21:26:00 +0200
commit36f962618047f44aa5c3aa4f549fbecc2419b667 (patch)
tree085e9a030725f1e0b6e4a764e633a8dda99f85d6
downloadaur-36f962618047f44aa5c3aa4f549fbecc2419b667.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--Makefile39
-rw-r--r--Makefile280
-rwxr-xr-xPKGBUILD61
4 files changed, 197 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bb83c7ca7aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = aesthe-svn
+ pkgdesc = 3d modeller
+ pkgver = 164
+ pkgrel = 1
+ url = http://sourceforge.net/projects/aesthe/
+ arch = i686
+ license = unknown
+ makedepends = subversion
+ depends = lua
+ depends = sdl
+ source = Makefile
+ source = Makefile2
+ md5sums = 6d79159605fd7081c3ab844954238977
+ md5sums = 2bb71fb2103af5a039ae8c6f1a6e33a0
+
+pkgname = aesthe-svn
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..5fe913353f72
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,39 @@
+PROJECT = aesthe
+USR_PATH = $(PKGDIR)/usr
+INSTALL_OPTS = -o root -g root -v
+INSTALL_OPTS_2 = $(INSTALL_OPTS_BIN) -m 644
+
+all:
+ cd src; make all
+
+clean:
+ cd src; make clean
+
+run:
+ cd src; make run
+
+runexamples:
+ cd src; make runexamples
+
+install: all uninstall
+ install -d $(USR_PATH)/bin
+ install -d $(USR_PATH)/share
+ install $(INSTALL_OPTS) -d $(USR_PATH)/share/$(PROJECT)
+ install $(INSTALL_OPTS) -d $(USR_PATH)/share/$(PROJECT)/image
+ install $(INSTALL_OPTS) -d $(USR_PATH)/share/$(PROJECT)/image/example
+ install $(INSTALL_OPTS) -d $(USR_PATH)/share/$(PROJECT)/model
+ install $(INSTALL_OPTS) -d $(USR_PATH)/share/$(PROJECT)/model/example
+ install $(INSTALL_OPTS) -d $(USR_PATH)/share/$(PROJECT)/script
+ install $(INSTALL_OPTS) -d $(USR_PATH)/share/$(PROJECT)/script/example
+ install $(INSTALL_OPTS) bin/aesthe $(USR_PATH)/bin
+ install $(INSTALL_OPTS_2) image/*.ppm $(USR_PATH)/share/$(PROJECT)/image
+ install $(INSTALL_OPTS_2) image/example/*.ppm $(USR_PATH)/share/$(PROJECT)/image/example
+ install $(INSTALL_OPTS_2) model/example/*.aexi $(USR_PATH)/share/$(PROJECT)/model/example
+ install $(INSTALL_OPTS_2) script/*.lua $(USR_PATH)/share/$(PROJECT)/script
+ install $(INSTALL_OPTS_2) script/example/*.lua $(USR_PATH)/share/$(PROJECT)/script/example
+
+uninstall:
+ rm -f $(USR_PATH)/bin/aesthe
+ rm -rf $(USR_PATH)/share/$(PROJECT)
+
+
diff --git a/Makefile2 b/Makefile2
new file mode 100644
index 000000000000..296aadd5badc
--- /dev/null
+++ b/Makefile2
@@ -0,0 +1,80 @@
+CC = gcc
+
+CFLAGS = -Wall -pedantic
+CFLAGS += -I../inc_priv -I../inc_pub
+CFLAGS += `pkg-config --cflags lua sdl`
+CFLAGS += -g
+CFLAGS += '-DAE_SEARCH_PATH_SHARE="/usr//share/aesthe"'
+#CFLAGS += -DDEBUG_FLAG
+
+LDFLAGS = -lm -lGL -lGLU
+LDFLAGS += `pkg-config --libs lua5.1 sdl`
+
+PROJECT = aesthe
+OBJS = ae_common.o ae_algebra.o ae_list.o ae_kernel.o ae_render.o ae_engine.o ae_console.o ae_image.o ae_texture.o ae_eximport.o ae_net.o ae_main.o
+
+all: usage build
+#all: usage build run
+#all: usage build valgrind
+
+usage:
+ ######################### Usage #########################
+ # make all - builds aesthe #
+ # make clean - cleans *.o and binary #
+ # make run - runs Aesthe #
+ # make runexamples - runs Aesthe with examples #
+ #########################################################
+ # To build Aesthe you need have installed: #
+ # 1. liblua version 5.1 (development package) #
+ # 2. SDL (development package) #
+ # 3. pkg-config installed and properly configured #
+ #########################################################
+
+
+# --- Build targets: ---
+
+build: $(PROJECT)
+
+$(PROJECT): $(OBJS)
+ $(CC) $(LDFLAGS) -o $(PROJECT) $(OBJS) $(LDLIBS)
+ mkdir -p ../bin
+ cp $(PROJECT) ../bin
+
+%.o: %.c
+ $(CC) -c $(CFLAGS) $< -o $@
+
+clean:
+ rm -f $(PROJECT) $(OBJS)
+
+
+# --- Run targets: ---
+
+run: build
+ cd ..; bin/$(PROJECT)
+
+runexamples: build
+ cd ..; bin/$(PROJECT) -d1024x768 -sexample/examples
+
+trace: build
+ cd ..; ltrace bin/$(PROJECT) 2>&1 | grep gl
+
+valgrind:
+ #cd ..; valgrind --tool=massif bin/$(PROJECT) 2>&1
+ cd ..; valgrind --tool=memcheck bin/$(PROJECT) 2>&1
+
+
+# --- Other targets: ---
+
+doc: build
+ cd ..; bin/$(PROJECT) -sdoc 2>/dev/null > doc/help.dpp
+ cd ../doc; make
+
+arch: clean
+ cd ..; mkdir -p archive
+ cd ..; tar c '--exclude=*.svn*' inc_priv inc_pub src image script model/example doc win32/Makefile win32/*.bat win32/LICENSE* Makefile README LICENSE | gzip > archive/$(PROJECT)_`date '+%Y-%m-%d_%H-%M-%S'`.tgz
+
+VERSION=`grep VERSION ../inc_priv/ae_common.h | sed -e 's/^[^"]*"\(.*\)\".*/\1/' | tr '.' '-'`
+release: clean
+ tar c -C ../.. '--exclude=*.svn*' aesthe/inc_priv aesthe/inc_pub aesthe/src aesthe/image aesthe/script aesthe/model/example aesthe/doc aesthe/win32/Makefile aesthe/Makefile aesthe/README aesthe/LICENSE | gzip > ../$(PROJECT)_$(VERSION)_unix_source.tgz
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..663a0f0e8024
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/Arch_CVS_&_SVN_PKGBUILD_guidelines
+# for more information on packaging from SVN sources.
+
+# Contributor: Rene Reigel <stormtrooperofdeath@gmx.net>
+pkgname=aesthe-svn
+pkgver=164
+pkgrel=1
+pkgdesc="3d modeller"
+arch=('i686')
+url="http://sourceforge.net/projects/aesthe/"
+license=('unknown')
+groups=()
+depends=('lua' 'sdl')
+makedepends=('subversion')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=(Makefile Makefile2)
+noextract=()
+md5sums=('6d79159605fd7081c3ab844954238977'
+ '2bb71fb2103af5a039ae8c6f1a6e33a0')
+
+
+
+_svntrunk=https://aesthe.svn.sourceforge.net/svnroot/aesthe
+_svnmod=aesthe
+
+build() {
+ cd "$srcdir"
+
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod && svn up -r $pkgver)
+ else
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ fi
+
+ msg "SVN checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_svnmod-build"
+ cp -r "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_svnmod-build/aesthe"
+ cp ../../../Makefile ./
+ cp ../../../Makefile2 ./src/Makefile
+ export PKGDIR=$pkgdir
+ #
+ # BUILD
+ #
+ #./autogen.sh
+ #./configure --prefix=/usr
+ make all || return 1
+ make install
+}