summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commitcd8c9fce693a2b809b9d783efc607c4f31518c62 (patch)
tree084ad8d6088764a8985da7ec63400c8b87b5e766
downloadaur-cd8c9fce693a2b809b9d783efc607c4f31518c62.tar.gz
Initial import
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD51
-rw-r--r--aether.sh2
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca8fac63c741
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = aether-git
+ pkgdesc = Distributed network that creates forum–like, anonymous and encrypted public spaces for its constituents
+ pkgver = 20141026
+ pkgrel = 1
+ url = https://github.com/nehbit/aether-public
+ arch = any
+ license = AGPL3
+ makedepends = git
+ depends = python2
+ depends = python2-cffi
+ depends = python2-characteristic
+ depends = python2-cryptography
+ depends = python2-miniupnpc
+ depends = python2-pif
+ depends = python2-pyasn1
+ depends = python2-pyasn1-modules
+ depends = python2-pycparser
+ depends = python2-pyopenssl
+ depends = python2-pyqt5
+ depends = python2-pytz
+ depends = python2-requests
+ depends = python2-service-identity
+ depends = python2-six
+ depends = python2-sqlalchemy
+ depends = python2-tendo
+ depends = python2-termcolor
+ depends = python2-twisted
+ depends = python2-ujson
+ depends = python2-wsgiref
+ depends = python2-zope-interface
+ depends = qt5-base
+ source = aether::git+https://github.com/nehbit/aether-public
+ source = aether.sh
+ sha256sums = SKIP
+ sha256sums = 7dee50b26626046bf8c4c010b10c4780e6bfb3c73a95c2bfe96d8e3f26d29f81
+
+pkgname = aether-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51cc306280ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=aether-git
+pkgver=20141026
+pkgrel=1
+pkgdesc="Distributed network that creates forum–like, anonymous and encrypted public spaces for its constituents"
+arch=('any')
+depends=('python2' 'python2-cffi' 'python2-characteristic' 'python2-cryptography' 'python2-miniupnpc' 'python2-pif' 'python2-pyasn1' 'python2-pyasn1-modules' 'python2-pycparser' 'python2-pyopenssl' 'python2-pyqt5' 'python2-pytz' 'python2-requests' 'python2-service-identity' 'python2-six' 'python2-sqlalchemy' 'python2-tendo' 'python2-termcolor' 'python2-twisted' 'python2-ujson' 'python2-wsgiref' 'python2-zope-interface' 'qt5-base')
+makedepends=('git')
+url="https://github.com/nehbit/aether-public"
+license=('AGPL3')
+source=(${pkgname%-git}::git+https://github.com/nehbit/aether-public
+ aether.sh)
+sha256sums=('SKIP'
+ '7dee50b26626046bf8c4c010b10c4780e6bfb3c73a95c2bfe96d8e3f26d29f81')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+prepare() {
+ cd ${pkgname%-git}
+
+ msg 'Fixing Non-ASCII character (\xc3) in qt5reactor.py...'
+ sed -i '1s/^/#coding: utf8 /' qt5reactor.py
+
+ msg 'Fixing Python version...'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python#/usr/bin/python2#g'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/env python#/usr/bin/env python2#g'
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg 'Installing license...'
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/aether/LICENSE"
+
+ msg 'Installing documentation...'
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/aether/README.md"
+
+ msg 'Installing...'
+ install -dm 755 "$pkgdir/usr/share/aether"
+ find . -mindepth 1 -maxdepth 1 \
+ -prune ! -name "README.md" \
+ -prune ! -name "LICENSE" \
+ -exec cp -dpr --no-preserve=ownership '{}' "$pkgdir/usr/share/aether" \;
+
+ msg 'Installing executable...'
+ install -Dm 755 "$srcdir/aether.sh" "$pkgdir/usr/bin/aether"
+}
diff --git a/aether.sh b/aether.sh
new file mode 100644
index 000000000000..09610b352bda
--- /dev/null
+++ b/aether.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+cd /usr/share/aether && /usr/bin/python2 main.py