summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe Tumultuous Unicorn Of Darkness2023-06-03 19:48:34 +0200
committerThe Tumultuous Unicorn Of Darkness2023-06-03 19:48:34 +0200
commit57dadcae8e9e3a4e4c360c6eb50e98061c2c476f (patch)
treea820c5870b56735397ac09eb2f7b72315894a9ba
parent5b8efe6f5c07da8bc975524750258478a047e20f (diff)
downloadaur-afancontrol.tar.gz
Adopt package, fix 404 error with afancontrol-3.1.0.tar.gz.asc file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47d61f273876..e0b75158a1e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = afancontrol
pkgdesc = Advanced fan control daemon
pkgver = 3.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/KostyaEsmukov/afancontrol
arch = any
license = MIT
@@ -20,8 +20,8 @@ pkgbase = afancontrol
optdepends = python-pyserial: Arduino support
optdepends = python-prometheus_client: Prometheus support
backup = etc/afancontrol/afancontrol.conf
- source = afancontrol-3.1.0.tar.gz::https://files.pythonhosted.org/packages/source/a/afancontrol/afancontrol-3.1.0.tar.gz
- source = afancontrol-3.1.0.tar.gz.asc::https://files.pythonhosted.org/packages/source/a/afancontrol/afancontrol-3.1.0.tar.gz.asc
+ source = afancontrol-3.1.0.tar.gz::https://files.pythonhosted.org/packages/b4/6b/50d7cd7693c21f4fcb48e77a79bea4e6de550f35879bcaf0cc82515667cc/afancontrol-3.1.0.tar.gz
+ source = afancontrol-3.1.0.tar.gz.asc::https://files.pythonhosted.org/packages/b4/6b/50d7cd7693c21f4fcb48e77a79bea4e6de550f35879bcaf0cc82515667cc/afancontrol-3.1.0.tar.gz.asc
source = LICENSE
validpgpkeys = A18FE9F6F570D5B4E1E1853FAA7B5406547AF062
sha256sums = 1403995a84a2ec880e36d36ca54c51e21e459e492b36b13437ceb5b792c7a46c
diff --git a/PKGBUILD b/PKGBUILD
index d490bd9a9d52..e589b5d1db1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,12 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: UnicornDarkness
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Artem Klevtsov <a.a.klevtsov@gmail com>
pkgname=afancontrol
pkgver=3.1.0
-pkgrel=1
+pkgrel=2
+_pypi_hash="b4/6b/50d7cd7693c21f4fcb48e77a79bea4e6de550f35879bcaf0cc82515667cc"
pkgdesc="Advanced fan control daemon"
arch=('any')
url="https://github.com/KostyaEsmukov/afancontrol"
@@ -18,8 +20,8 @@ optdepends=('lm_sensors: to use the motherboard-based sensors and PWM fans'
'python-pyserial: Arduino support'
'python-prometheus_client: Prometheus support')
backup=("etc/$pkgname/$pkgname.conf")
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/a/$pkgname/$pkgname-$pkgver.tar.gz"
- "$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/a/$pkgname/$pkgname-$pkgver.tar.gz.asc"
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/$_pypi_hash/afancontrol-3.1.0.tar.gz"
+ "$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/$_pypi_hash/afancontrol-3.1.0.tar.gz.asc"
'LICENSE')
sha256sums=('1403995a84a2ec880e36d36ca54c51e21e459e492b36b13437ceb5b792c7a46c'
'SKIP'
@@ -46,7 +48,7 @@ check() {
package() {
cd "$pkgname-$pkgver"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dvm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dvm644 "pkg/$pkgname.conf" -t "$pkgdir/etc/$pkgname/"
}