summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe Tumultuous Unicorn Of Darkness2025-01-20 20:22:20 +0100
committerThe Tumultuous Unicorn Of Darkness2025-01-20 20:22:20 +0100
commit466974ac03c3855478f12d69289ede2eee509181 (patch)
tree6ab52628e2f97dbc34903c8dfef13caccedde28a
parent57dadcae8e9e3a4e4c360c6eb50e98061c2c476f (diff)
downloadaur-466974ac03c3855478f12d69289ede2eee509181.tar.gz
Add license for package sources
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--LICENSE22
-rw-r--r--MIT.txt21
-rw-r--r--PKGBUILD4
5 files changed, 31 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0b75158a1e7..b67f80e9e4a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,7 +22,7 @@ pkgbase = afancontrol
backup = etc/afancontrol/afancontrol.conf
source = afancontrol-3.1.0.tar.gz::https://files.pythonhosted.org/packages/b4/6b/50d7cd7693c21f4fcb48e77a79bea4e6de550f35879bcaf0cc82515667cc/afancontrol-3.1.0.tar.gz
source = afancontrol-3.1.0.tar.gz.asc::https://files.pythonhosted.org/packages/b4/6b/50d7cd7693c21f4fcb48e77a79bea4e6de550f35879bcaf0cc82515667cc/afancontrol-3.1.0.tar.gz.asc
- source = LICENSE
+ source = MIT.txt
validpgpkeys = A18FE9F6F570D5B4E1E1853FAA7B5406547AF062
sha256sums = 1403995a84a2ec880e36d36ca54c51e21e459e492b36b13437ceb5b792c7a46c
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..b582a20a9c92 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,5 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!LICENSE
+!MIT.txt
diff --git a/LICENSE b/LICENSE
index 5785e466a1ed..733e88560b9d 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,21 +1,9 @@
-MIT License
+Binary files, as well as any files describing changes ("patches") to the software that is being built are excluded from this license. They are provided under the license terms of the software they describe changes for.
-Copyright (c) 2019 Kostya Esmukov <kostya@esmukov.ru>
+Any files containing a license notice are excluded from this license. They are provided under the license terms defined in their respective notices.
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
+Copyright 2024 Arch Linux Contributors
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
+Permission to use, copy, modify, and/or distribute this software for any purpose with or without fee is hereby granted.
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
+THE SOFTWARE IS PROVIDED “AS IS” AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/MIT.txt b/MIT.txt
new file mode 100644
index 000000000000..5785e466a1ed
--- /dev/null
+++ b/MIT.txt
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 Kostya Esmukov <kostya@esmukov.ru>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index e589b5d1db1b..98f924c051b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ optdepends=('lm_sensors: to use the motherboard-based sensors and PWM fans'
backup=("etc/$pkgname/$pkgname.conf")
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/$_pypi_hash/afancontrol-3.1.0.tar.gz"
"$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/$_pypi_hash/afancontrol-3.1.0.tar.gz.asc"
- 'LICENSE')
+ 'MIT.txt')
sha256sums=('1403995a84a2ec880e36d36ca54c51e21e459e492b36b13437ceb5b792c7a46c'
'SKIP'
'cfbf3d258bc1990f8633f0751cf14515500938a6949ff413f6491dfe4b804d1a')
@@ -49,6 +49,6 @@ check() {
package() {
cd "$pkgname-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dvm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm644 "$srcdir/MIT.txt" -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dvm644 "pkg/$pkgname.conf" -t "$pkgdir/etc/$pkgname/"
}