summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Gorshkov2021-02-08 16:47:21 +0300
committerAndrey Gorshkov2021-02-08 16:47:21 +0300
commit679b2a2555d7bc0d3dd574ab4a469c5442a32fe3 (patch)
treee903e017d974b5afb4a8b2ea8c5258faf014be06
downloadaur-679b2a2555d7bc0d3dd574ab4a469c5442a32fe3.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4520ab2babf8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = afetch-asm-git
+ pkgdesc = A command-line system information tool written in x86 assembly language
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/sticky-tea/afetch
+ arch = x86
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = fasm
+ makedepends = make
+ optdepends = lsb-release: OS information
+ provides = afetch
+ conflicts = afetch
+ source = afetch-asm-git::git+https://github.com/sticky-tea/afetch
+ md5sums = SKIP
+
+pkgname = afetch-asm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e10b8091cb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Andrey Gorshkov <spacebiker@airmail.cc>
+
+pkgname=afetch-asm-git
+_pkgname=afetch-asm
+pkgver=1
+pkgrel=1
+epoch=
+pkgdesc="A command-line system information tool written in x86 assembly language"
+arch=("x86" "x86_64")
+url="https://github.com/sticky-tea/afetch"
+license=('GPL')
+groups=()
+depends=()
+makedepends=(
+ 'git'
+ 'fasm'
+ 'make'
+)
+checkdepends=()
+optdepends=('lsb-release: OS information')
+provides=('afetch')
+conflicts=('afetch')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}::git+https://github.com/sticky-tea/afetch"
+)
+noextract=()
+md5sums=("SKIP")
+
+
+build()
+{
+ cd "$_pkgname"
+ make all
+}
+
+package()
+{
+ cd "$_pkgname"
+ make install
+}