summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFronkles McFranko2020-10-19 22:22:46 -0700
committerFronkles McFranko2020-10-19 22:22:46 -0700
commit7ab225dde2304b34bcdb1db6994db30d0a9a9a5f (patch)
tree806a6b6fbf88b1792601f11f4e62a0c29ac2cda2
downloadaur-7ab225dde2304b34bcdb1db6994db30d0a9a9a5f.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--Makefile.patch12
-rw-r--r--PKGBUILD45
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..230721fa3495
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = afetch-git
+ pkgdesc = Fast and simple system info written in C, that can be configured at compile time by editing the config.h file
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/13-CF/afetch
+ arch = any
+ license = GPL
+ source = git+https://github.com/13-CF/afetch
+ source = Makefile.patch
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = afetch
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..0e16958148fb
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,12 @@
+19,20c19,22
+< cp ./afetch /usr/local/bin/afetch
+< chmod 711 /usr/local/bin/afetch
+---
+> mkdir -p ${DESTDIR}/${PREFIX}/bin
+>
+> cp ./afetch ${DESTDIR}/${PREFIX}/bin/afetch
+> chmod 711 ${DESTDIR}/${PREFIX}/bin/afetch
+22c24
+< rm -f /usr/local/bin/afetch
+---
+> rm -f ${DESTDIR}/${PREFIX}/bin/afetch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a8aafeb4b7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgbase=afetch-git
+pkgname=afetch
+pkgver=1
+pkgrel=1
+epoch=
+pkgdesc="Fast and simple system info written in C, that can be configured at compile time by editing the config.h file"
+arch=("any")
+url="https://github.com/13-CF/afetch"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(afetch)
+conflicts=(afetch)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/13-CF/afetch"
+ "Makefile.patch")
+noextract=()
+md5sums=("SKIP" "SKIP")
+
+prepare() {
+ patch "$pkgname/Makefile" -i Makefile.patch
+}
+
+build() {
+ cd "$pkgname"
+ make all
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" PREFIX="/usr/" install
+}