diff options
author | Daniel M. Capella | 2019-04-21 23:19:19 -0400 |
---|---|---|
committer | Daniel M. Capella | 2019-04-26 16:48:36 -0400 |
commit | 88005383f55885abf000ddb22ee9c99dbf0d8dca (patch) | |
tree | 5a07acb27cbd11dcb5473061f44018a08a31a222 | |
parent | 392803e85c14ce37af40467c82fe970b1fe9e393 (diff) | |
download | aur-88005383f55885abf000ddb22ee9c99dbf0d8dca.tar.gz |
Update and make consistent with stable package
- Add egg-info command for test_all_builtin_FilterRegistrys_exist test
- Add SETUPTOOLS_SCM_PRETEND_VERSION "hack" to run Sphinx build
If this is set to the version from afew/version.py, it will get
truncated to '1.3.1'; might as well use `--version=$pkgver` to avoid
confusion.
https://github.com/afewmail/afew/commit/330cd3153039c6038d5265e21ee4a74d1e184405
-rw-r--r-- | .SRCINFO | 19 | ||||
-rw-r--r-- | LICENSE | 15 | ||||
-rw-r--r-- | PKGBUILD | 50 |
3 files changed, 35 insertions, 49 deletions
@@ -1,22 +1,21 @@ pkgbase = afew-git - pkgdesc = afew is an initial tagging script for notmuch mail - pkgver = 1.0.0.r21.g6f4244e - pkgrel = 2 + pkgdesc = Initial tagging script for notmuch mail + pkgver = 1.3.0.r57.g3bb53db + pkgrel = 1 epoch = 1 - url = https://github.com/teythoon/afew + url = https://github.com/afewmail/afew arch = any license = custom:BSD makedepends = git + makedepends = python-setuptools-scm makedepends = python-sphinx - depends = python depends = notmuch - depends = dbacl depends = python-chardet - depends = python-setuptools depends = python-dkim - source = LICENSE - source = git://github.com/teythoon/afew.git - md5sums = 295b245540aa61538f9a3556c4be846c + depends = python-setuptools + provides = afew + conflicts = afew + source = git+https://github.com/afewmail/afew.git md5sums = SKIP pkgname = afew-git diff --git a/LICENSE b/LICENSE deleted file mode 100644 index aab8c362406..00000000000 --- a/LICENSE +++ /dev/null @@ -1,15 +0,0 @@ -# -# Copyright (c) Justus Winter <4winter@informatik.uni-hamburg.de> -# -# Permission to use, copy, modify, and distribute this software for any -# purpose with or without fee is hereby granted, provided that the above -# copyright notice and this permission notice appear in all copies. -# -# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES -# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF -# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR -# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES -# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN -# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF -# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. -# @@ -1,42 +1,44 @@ # Maintainer: Giancarlo Razzolini <grazzolini@archlinux.org> +# Maintainer: Daniel M. Capella <polyzen@archlinux.org> # Contributor: Kazuo Teramoto <kaz.rag at gmail.com> + pkgname=afew-git -pkgver=1.0.0.r21.g6f4244e -pkgrel=2 +pkgver=1.3.0.r57.g3bb53db +pkgrel=1 epoch=1 -pkgdesc="afew is an initial tagging script for notmuch mail" +pkgdesc='Initial tagging script for notmuch mail' arch=(any) -url="https://github.com/teythoon/afew" +url=https://github.com/afewmail/afew license=('custom:BSD') -depends=('python' 'notmuch' 'dbacl' 'python-chardet' 'python-setuptools' 'python-dkim') -makedepends=('git' 'python-sphinx') -source=('LICENSE' 'git://github.com/teythoon/afew.git') -md5sums=('295b245540aa61538f9a3556c4be846c' - 'SKIP') +depends=('notmuch' 'python-chardet' 'python-dkim' 'python-setuptools') +makedepends=('git' 'python-setuptools-scm' 'python-sphinx') +provides=('afew') +conflicts=('afew') +source=("git+$url.git") +md5sums=('SKIP') pkgver() { - cd "$srcdir/afew" - - git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' + cd afew + git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' } build() { - cd "$srcdir/afew" - - python setup.py build + cd afew + python setup.py build egg_info + export SETUPTOOLS_SCM_PRETEND_VERSION=1 + python setup.py build_sphinx -b man --version $pkgver +} - make -C docs man +check() { + cd afew + python -m unittest discover afew/tests } package() { - cd "$srcdir/afew" - - python setup.py install --root="$pkgdir" --optimize=1 - - install -D -m 644 docs/build/man/afew.1 "$pkgdir/usr/share/man/man1/afew.1" - - install -D -m644 "$srcdir/LICENSE" \ - "$pkgdir/usr/share/licenses/$pkgname/LICENSE" + cd afew + python setup.py install --root="$pkgdir" --optimize=1 --skip-build + install -Dm644 -t "$pkgdir"/usr/share/man/man1 build/sphinx/man/afew.1 + install -Dm644 -t "$pkgdir"/usr/share/licenses/afew LICENSE } # vim:set ts=2 sw=2 et: |