summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Lipp2015-06-15 20:15:07 +0200
committerMoritz Lipp2015-06-15 20:15:07 +0200
commitaafe7b4d2ae290bf0c87af9ca6afffbe527ae335 (patch)
treecba58bf24208f63f72dc6cdac03939296f4cbf9e
downloadaur-aafe7b4d2ae290bf0c87af9ca6afffbe527ae335.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE15
-rw-r--r--PKGBUILD36
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77b687992667
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = afew-git
+ pkgdesc = afew is an initial tagging script for notmuch mail
+ pkgver = 0.203.d5d0dde
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/teythoon/afew
+ arch = any
+ license = custom:BSD
+ makedepends = git
+ depends = python
+ depends = notmuch
+ depends = dbacl
+ depends = python-chardet
+ depends = python-setuptools
+ source = LICENSE
+ source = git://github.com/teythoon/afew.git
+ md5sums = 295b245540aa61538f9a3556c4be846c
+ md5sums = SKIP
+
+pkgname = afew-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..aab8c3624063
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,15 @@
+#
+# Copyright (c) Justus Winter <4winter@informatik.uni-hamburg.de>
+#
+# Permission to use, copy, modify, and distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+#
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea9ac1dba71b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Kazuo Teramoto <kaz.rag at gmail.com>
+pkgname=afew-git
+pkgver=0.203.d5d0dde
+pkgrel=1
+epoch=1
+pkgdesc="afew is an initial tagging script for notmuch mail"
+arch=(any)
+url="https://github.com/teythoon/afew"
+license=('custom:BSD')
+depends=('python' 'notmuch' 'dbacl' 'python-chardet' 'python-setuptools')
+makedepends=('git')
+source=('LICENSE' 'git://github.com/teythoon/afew.git')
+md5sums=('295b245540aa61538f9a3556c4be846c' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/afew"
+
+ echo "0.$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+build() {
+ cd "$srcdir/afew"
+
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/afew"
+
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -D -m644 "$srcdir/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: