summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeimos2018-09-19 17:30:28 -0400
committerDeimos2018-09-19 17:30:28 -0400
commita7c977cbcf5785b6d45e7f532ba9c49cdd4ab3eb (patch)
tree2bb62e0e58bb5a125b4ec76d4291a465d4629eb4
downloadaur-a7c977cbcf5785b6d45e7f532ba9c49cdd4ab3eb.tar.gz
Stage for AUR
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11f3dc721cb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = affiche.app
+ pkgdesc = An application to "stick" little notes on the desktop
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://packages.debian.org/stretch/gnustep/affiche.app
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ groups = gnustep-apps
+ license = GPL
+ makedepends = gcc-objc
+ makedepends = gnustep-make
+ depends = gnustep-base
+ depends = gnustep-gui
+ depends = gnustep-back
+ source = http://http.debian.net/debian/pool/main/a/affiche/affiche_0.6.0.orig.tar.gz
+ sha256sums = 4bb170c4c33cc84cc5ecb87c02395154426f4dd9d9e3a97d45782317b70e1de4
+
+pkgname = affiche.app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..041c8e9e82af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+_pkgname=Affiche
+pkgname=affiche.app
+pkgrel=1
+pkgver=0.6.0
+pkgdesc='An application to "stick" little notes on the desktop'
+arch=('i686' 'x86_64' 'armv7h')
+url='https://packages.debian.org/stretch/gnustep/affiche.app'
+license=('GPL')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("http://http.debian.net/debian/pool/main/a/affiche/affiche_0.6.0.orig.tar.gz")
+sha256sums=('4bb170c4c33cc84cc5ecb87c02395154426f4dd9d9e3a97d45782317b70e1de4')
+
+build() {
+ cd "affiche-$pkgver.orig"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd "affiche-$pkgver.orig"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file