summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Kerrick2023-05-17 19:28:59 -0400
committerEthan Kerrick2023-05-17 19:28:59 -0400
commit91a9bc58fd0ed4b67993e7494fa32eb10005b829 (patch)
tree8f0b4c281ca3fd09adba3757ac2ef081bf949100
parent952963599e267c63000626d9bda380caf9e53c15 (diff)
downloadaur-91a9bc58fd0ed4b67993e7494fa32eb10005b829.tar.gz
updated to 3.7.20, added dependencies, added custom license
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD7
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de308d65401d..81252444193c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = afflib
pkgdesc = An extensible open format for the storage of disk images and related forensic information
- pkgver = 3.7.19
+ pkgver = 3.7.20
pkgrel = 1
url = https://github.com/sshock/AFFLIBv3/
arch = i686
@@ -9,8 +9,12 @@ pkgbase = afflib
depends = zlib
depends = openssl
depends = fuse
- source = https://github.com/sshock/AFFLIBv3/archive/v3.7.19.tar.gz
- sha256sums = d358b07153dd08df3f35376bab0202c6103808686bab5e8486c78a18b24e2665
+ depends = readline
+ depends = gcc-libs
+ depends = libmd
+ depends = expat
+ depends = curl
+ source = https://github.com/sshock/AFFLIBv3/archive/v3.7.20.tar.gz
+ sha256sums = 7264d705ff53185f0847c69abdfce072779c0b907257e087a6372c7608108f65
pkgname = afflib
-
diff --git a/PKGBUILD b/PKGBUILD
index 3f055812b852..f07825c7049b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,15 @@
# Contributor: watashi <zejun dot wu at gmail dot com>
pkgname=afflib
-pkgver=3.7.19
+pkgver=3.7.20
pkgrel=1
pkgdesc="An extensible open format for the storage of disk images and related forensic information"
arch=('i686' 'x86_64')
url="https://github.com/sshock/AFFLIBv3/"
license=('custom')
-depends=('zlib' 'openssl' 'fuse')
+depends=('zlib' 'openssl' 'fuse' 'readline' 'gcc-libs' 'libmd' 'expat' 'curl')
source=("https://github.com/sshock/AFFLIBv3/archive/v${pkgver}.tar.gz")
-sha256sums=('d358b07153dd08df3f35376bab0202c6103808686bab5e8486c78a18b24e2665')
+sha256sums=('7264d705ff53185f0847c69abdfce072779c0b907257e087a6372c7608108f65')
build() {
cd "${srcdir}"/AFFLIBv3-${pkgver}
@@ -25,4 +25,5 @@ build() {
package() {
cd "${srcdir}"/AFFLIBv3-${pkgver}
make DESTDIR="${pkgdir}" install
+ install -Dm755 "COPYING" "${pkgdir}/usr/share/licenses/afflib/LICENSE"
}