summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit81c96813cecc9678df92e9f1a6886c71b627dfb6 (patch)
treebb82852191d22e4f3f1c9382a01c4dccb6179651
downloadaur-81c96813cecc9678df92e9f1a6886c71b627dfb6.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a183b728244d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = afick
+ pkgdesc = Alternative to tripwire
+ pkgver = 2.14
+ pkgrel = 1
+ url = http://afick.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = perl
+ depends = perl-tk
+ source = http://downloads.sourceforge.net/afick/afick-2.14-1.tgz
+ md5sums = 74b85916767a45c024a4dc125547f6a2
+
+pkgname = afick
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a2828f576bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Rorschach <r0rschach@lavabit.com
+# Maintainer: Nathan Owe <ndowens04+AUR @ gmail.com>
+pkgname=afick
+pkgver=2.14
+_realpkgver=2.14-1
+pkgrel=1
+pkgdesc="Alternative to tripwire"
+url="http://afick.sourceforge.net"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('perl' 'perl-tk')
+source=(http://downloads.sourceforge.net/afick/afick-$_realpkgver.tgz)
+md5sums=('74b85916767a45c024a4dc125547f6a2')
+
+build() {
+ cd $srcdir/$pkgname-$_realpkgver
+ perl Makefile.pl
+ make || return 1
+ make DESTDIR=$pkgdir/ install
+ chmod a+r $pkgdir/etc/{afick.conf,cron.daily/afick_cron}
+ chmod a+rx $pkgdir/{etc/logrotate.d,var/{log/afick,lib/afick,lib/afick/archive}}
+}