summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-10-08 00:45:22 +0200
committeranthraxx2015-10-08 00:45:22 +0200
commitb2ee6f35f3e7d9fe40015a77a2ec261ebfac6941 (patch)
treec568f1be130b30ca4c07de3ba937af0d1e45c8a5
downloadaur-b2ee6f35f3e7d9fe40015a77a2ec261ebfac6941.tar.gz
addpkg: afl-utils-git 1.17a.75.26a05d0-1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62d5b60d949a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = afl-utils-git
+ pkgdesc = Utilities for automated crash sample processing/analysis, easy afl-fuzz job management and corpus optimization
+ pkgver = 1.17a.75.26a05d0
+ pkgrel = 1
+ url = https://github.com/rc0r/afl-utils
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = python-setuptools
+ depends = afl
+ depends = coreutils
+ depends = python
+ optdepends = sqlite: database support
+ optdepends = screen: interactive/screen mode support
+ optdepends = gdb: gdb script execution support
+ optdepends = python-twitter: afl-stat support
+ provides = afl-utils
+ conflicts = afl-utils
+ source = afl-utils-git::git+https://github.com/rc0r/afl-utils
+ sha512sums = SKIP
+
+pkgname = afl-utils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dca72f8d407a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+
+pkgname=afl-utils-git
+_gitname=afl-utils
+pkgver=1.17a.75.26a05d0
+pkgrel=1
+pkgdesc="Utilities for automated crash sample processing/analysis, easy afl-fuzz job management and corpus optimization"
+url="https://github.com/rc0r/afl-utils"
+arch=('any')
+license=('Apache')
+depends=('afl' 'coreutils' 'python')
+optdepends=(
+ 'sqlite: database support'
+ 'screen: interactive/screen mode support'
+ 'gdb: gdb script execution support'
+ 'python-twitter: afl-stat support'
+)
+makedepends=('git' 'python-setuptools')
+provides=('afl-utils')
+conflicts=('afl-utils')
+source=(${pkgname}::git+https://github.com/rc0r/${_gitname})
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|cut -dv -f2|cut -d- -f1)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${pkgname}
+ python setup.py install -O1 --root="${pkgdir}"
+ install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm 644 docs/CHANGELOG.md "${pkgdir}/usr/share/doc/${pkgname}/CHANGELOG.md"
+ install -Dm 644 afl-stats.conf.sample "${pkgdir}/usr/share/doc/${pkgname}/afl-stats.conf.sample"
+}
+
+# vim: ts=2 sw=2 et: