summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2020-07-26 10:53:27 -0400
committerGI_Jack2020-07-26 10:53:27 -0400
commitef4d0e24dc443f44990ad52f36839288b9970d44 (patch)
treeceff05b92078349f66cb0d6a71cc4706c151cddb
downloadaur-ef4d0e24dc443f44990ad52f36839288b9970d44.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b272490f56f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aflplusplus
+ pkgdesc = afl++ is afl with community patches, AFLfast power schedules, qemu 3.1 upgrade + laf-intel support, MOpt mutators, InsTrim instrumentation, unicorn_mode and a lot more!
+ pkgver = 2.66c
+ pkgrel = 1
+ url = https://github.com/vanhauser-thc/AFLplusplus
+ arch = x86_64
+ license = Apache
+ optdepends = qemu: use QEMU with afl
+ provides = afl
+ conflicts = afl
+ source = https://github.com/AFLplusplus/AFLplusplus/archive/2.66c.tar.gz
+ sha256sums = d71c4126d6ea733aa4366339ae81ae73a47f8a8ce8dddc05bddf3ed28c8fadf7
+
+pkgname = aflplusplus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a3e65a045a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer GI Jack <GI_Jack@hackermail.com>
+
+pkgname=aflplusplus
+pkgver=2.66c
+pkgrel=1
+pkgdesc="afl++ is afl with community patches, AFLfast power schedules, qemu 3.1 upgrade + laf-intel support, MOpt mutators, InsTrim instrumentation, unicorn_mode and a lot more!"
+arch=('x86_64')
+url="https://github.com/vanhauser-thc/AFLplusplus"
+license=('Apache')
+provides=('afl')
+conflicts=('afl')
+optdepends=('qemu: use QEMU with afl')
+source=("https://github.com/AFLplusplus/AFLplusplus/archive/${pkgver}.tar.gz")
+sha256sums=('d71c4126d6ea733aa4366339ae81ae73a47f8a8ce8dddc05bddf3ed28c8fadf7')
+
+build() {
+ cd "AFLplusplus-${pkgver}"
+ make PREFIX="/usr"
+ make llvm_mode PREFIX="/usr"
+}
+
+package() {
+ cd "AFLplusplus-${pkgver}"
+ make install PREFIX="/usr" DESTDIR="${pkgdir}"
+}
+