summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororiginalsouth2022-07-15 19:11:14 +0200
committerBenny2022-07-15 19:11:14 +0200
commitb2cd40c9c1399d4e7a3ebf0b8e546b84e3e51d50 (patch)
treebfac90dc20eaa0681973053402545f9f8ac951e3
parentfa8d0459d6b65c435a3c20672ec47421e9e73262 (diff)
downloadaur-b2cd40c9c1399d4e7a3ebf0b8e546b84e3e51d50.tar.gz
update
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbc965bad126..4617cf2bafbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,27 @@
# Maintainer: B.C. van Zuiden <zuiden@ilorentz.org>
_pkgname=aflplusplus
pkgname=${_pkgname}-git
-pkgver=2.54c
+pkgver=4.01c.r49.gc57988e6
pkgrel=1
-pkgdesc="afl++ is afl with community patches, AFLfast power schedules, qemu 3.1 upgrade + laf-intel support, MOpt mutators, InsTrim instrumentation, unicorn_mode and a lot more!"
+pkgdesc="The fuzzer afl++ is afl with community patches, qemu 5.1 upgrade, collision-free coverage, enhanced laf-intel & redqueen, AFLfast++ power schedules, MOpt mutators, unicorn_mode, and a lot more!"
arch=('x86_64')
-url="https://github.com/vanhauser-thc/AFLplusplus"
+url="https://github.com/AFLplusplus/AFLplusplus"
license=('Apache')
makedepends=('git')
provides=('afl')
conflicts=('afl')
-source=('git://github.com/vanhauser-thc/AFLplusplus.git')
+source=("git+https://github.com/AFLplusplus/AFLplusplus.git")
sha256sums=('SKIP')
+pkgver() {
+ cd AFLplusplus
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build()
{
cd AFLplusplus
make PREFIX="/usr"
- make llvm_mode PREFIX="/usr"
}
package()