summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororiginalsouth2019-09-24 17:48:45 +0200
committeroriginalsouth2019-09-24 17:48:45 +0200
commitfa8d0459d6b65c435a3c20672ec47421e9e73262 (patch)
tree2080449838eb850f9bd0e568f007732a69788787
downloadaur-fa8d0459d6b65c435a3c20672ec47421e9e73262.tar.gz
Initial
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d9b566b2a88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aflplusplus-git
+ pkgdesc = afl++ is afl with community patches, AFLfast power schedules, qemu 3.1 upgrade + laf-intel support, MOpt mutators, InsTrim instrumentation, unicorn_mode and a lot more!
+ pkgver = 2.54c
+ pkgrel = 1
+ url = https://github.com/vanhauser-thc/AFLplusplus
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ provides = afl
+ conflicts = afl
+ source = git://github.com/vanhauser-thc/AFLplusplus.git
+ sha256sums = SKIP
+
+pkgname = aflplusplus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbc965bad126
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: B.C. van Zuiden <zuiden@ilorentz.org>
+_pkgname=aflplusplus
+pkgname=${_pkgname}-git
+pkgver=2.54c
+pkgrel=1
+pkgdesc="afl++ is afl with community patches, AFLfast power schedules, qemu 3.1 upgrade + laf-intel support, MOpt mutators, InsTrim instrumentation, unicorn_mode and a lot more!"
+arch=('x86_64')
+url="https://github.com/vanhauser-thc/AFLplusplus"
+license=('Apache')
+makedepends=('git')
+provides=('afl')
+conflicts=('afl')
+source=('git://github.com/vanhauser-thc/AFLplusplus.git')
+sha256sums=('SKIP')
+
+build()
+{
+ cd AFLplusplus
+ make PREFIX="/usr"
+ make llvm_mode PREFIX="/usr"
+}
+
+package()
+{
+ cd AFLplusplus
+ make install PREFIX="/usr" DESTDIR="${pkgdir}"
+}