summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Mullins2016-06-28 21:48:00 -0400
committerChristopher Mullins2016-06-28 21:48:00 -0400
commitf3193e7006912a7514b89e52824f01b41e37a396 (patch)
treef3a31766e35058c7829bad6679b57212ab28f700
downloadaur-f3193e7006912a7514b89e52824f01b41e37a396.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--Makefile.patch73
-rw-r--r--PKGBUILD39
3 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcd0a4406fc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Wed Jun 29 01:47:04 UTC 2016
+pkgbase = afni
+ pkgdesc = An open-source environment for processing and displaying functional MRI data
+ pkgver = 16.1.27
+ pkgrel = 1
+ url = http://afni.nimh.nih.gov
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = tcsh
+ depends = python
+ depends = gcc-libs
+ depends = gsl
+ depends = libxpm
+ depends = glu
+ depends = lesstif
+ depends = libjpeg-turbo
+ depends = libxmu
+ depends = libxft
+ source = http://afni.nimh.nih.gov/pub/dist/tgz/afni_src.tgz
+ source = Makefile.patch
+ sha512sums = 9e43bb8184fa94ee872649a7ecb374097fb14155d948170079aeffbbc31966d0702aed9b14456a430cab4249ae585a9242b2c0ef0fddb572c8aadccdf0d1372b
+ sha512sums = 92737f013c50f7b84527415b9f8435d5f334a3b0169fcb2f6abdbcad2c2f09ce7709db89feaf74b624b7fd0fd216546e2e1fb2de14e29e8de6e0afd422216c6b
+
+pkgname = afni
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..daee13a33466
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,73 @@
+--- Makefile 2016-06-28 19:06:49.804833739 -0400
++++ Makefile 2016-06-28 19:10:33.958170494 -0400
+@@ -6,7 +6,7 @@
+ USE_ZLIB = -DHAVE_ZLIB
+ LZLIB = -lz
+ USE_GIFTI = -DHAVE_GIFTI
+-LGIFTI = /usr/lib64/libexpat.a
++LGIFTI = /usr/lib/libexpat.so
+
+ # ------------------------------
+ # python from C (off for now)
+@@ -17,7 +17,7 @@
+ # X configuration
+ #
+ # uncomment to build using local /usr/local/afniX 'X' tree
+-USE_LOCAL_X_TREE = 1
++#USE_LOCAL_X_TREE = 1
+ ifdef USE_LOCAL_X_TREE
+ XROOT = /usr/local/afniX
+ XROOT_I = -I$(XROOT)/include
+@@ -33,20 +33,22 @@
+ XLIBS = $(XROOT)/lib64/libXm.a $(XROOT)/lib64/libXt.a
+ else
+ # default is static motif
+- XLIBS = $(XROOT)/lib64/libXm.a -lXt
++ XLIBS = $(XROOT)/lib/libXm.so -lXt
+ endif
+
+ # in case user wants to override with system dynamic libs
+-# XLIBS = -lXm -lXt
++XLIBS = -lXm -lXt
+ # ----------------------------------------------------------------------
+
+ CCDEBS = -DAFNI_DEBUG -DIMSEQ_DEBUG -DDISPLAY_DEBUG -DTHD_DEBUG
+-CEXTRA = -Wcomment -Wformat -DUSE_TRACING -DHAVE_XDBE $(CPROF) -DDONT_USE_XTDESTROY $(LESSTIF_DEFS)
++#CEXTRA = -Wcomment -Wformat -DUSE_TRACING -DHAVE_XDBE $(CPROF) -DDONT_USE_XTDESTROY $(LESSTIF_DEFS)
++CEXTRA = -march=native -Wcomment -Wformat -DUSE_TRACING -DHAVE_XDBE $(CPROF) -DDONT_USE_XTDESTROY $(LESSTIF_DEFS)
+
+ CC = /usr/bin/gcc -O2 -m64 -fPIC -DREAD_WRITE_64 -DLINUX2 $(CEXTRA)
+ CCVOL = /usr/bin/gcc -O2 -m64 -fPIC -DREAD_WRITE_64 -DLINUX2 $(CEXTRA)
+ CCFAST = /usr/bin/gcc -O2 -m64 -fPIC -DREAD_WRITE_64 -DLINUX2 $(CEXTRA)
+-CCOLD = /usr/bin/gcc -V 34 -O2 -m64 -fPIC -DREAD_WRITE_64 -DLINUX2 $(CEXTRA)
++#CCOLD = /usr/bin/gcc -V 34 -O2 -m64 -fPIC -DREAD_WRITE_64 -DLINUX2 $(CEXTRA)
++CCOLD = ${CCFAST}
+
+ # The following line includes compiling for the SSE operations.
+ # However, I found that it actually makes things worse in some test code.
+@@ -59,14 +61,14 @@
+ CCD = $(CC) $(CCDEBS)
+
+ IFLAGS = -I. $(XROOT_I) -I/usr/include
+-LFLAGS = -L. -L/usr/lib64
++LFLAGS = -L. -L/usr/lib
+
+ CCSVD = /usr/bin/gcc -O0 -m64 -fPIC
+
+ PLUGIN_SUFFIX = so
+ PLUGIN_LFLAGS = -shared -fPIC
+ PLUGIN_CC = $(CC)
+-PLFLAGS = -rdynamic -L. -L/usr/lib64
++PLFLAGS = -rdynamic -L. -L/usr/lib
+
+ SYSTEM_NAME = linux_openmp_64
+ SHOWOFF = -DSHOWOFF=$(SYSTEM_NAME)
+@@ -84,7 +86,7 @@
+
+ LINT = /usr/bin/lint -a -b -u -v -x $(IFLAGS) $(CCDEFS)
+
+-INSTALLDIR = ./linux_openmp_64
++INSTALLDIR = ../build
+ LIBDIR = $(INSTALLDIR)
+
+ #INSTALL_PREREQ = suma
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2633aa3bd810
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Chris <christopher.r.mullins g-mail>
+# Contributor: cornholio <vigo.the.unholy.carpathian@gmail.com>
+pkgname=afni
+pkgver=16.1.27
+pkgrel=1
+pkgdesc="An open-source environment for processing and displaying functional MRI data"
+arch=("i686" "x86_64")
+url="http://afni.nimh.nih.gov"
+license=(custom)
+depends=("tcsh" "python" "gcc-libs" "gsl" "libxpm" "glu" "lesstif" "libjpeg-turbo" "libxmu" "libxft")
+source=('http://afni.nimh.nih.gov/pub/dist/tgz/afni_src.tgz' 'Makefile.patch')
+sha512sums=('9e43bb8184fa94ee872649a7ecb374097fb14155d948170079aeffbbc31966d0702aed9b14456a430cab4249ae585a9242b2c0ef0fddb572c8aadccdf0d1372b'
+ '92737f013c50f7b84527415b9f8435d5f334a3b0169fcb2f6abdbcad2c2f09ce7709db89feaf74b624b7fd0fd216546e2e1fb2de14e29e8de6e0afd422216c6b')
+
+prepare() {
+ cd "${srcdir}"/afni_src
+ cp Makefile.linux_openmp_64 Makefile
+ patch -Np0 -i ../Makefile.patch
+}
+
+build() {
+ cd ${srcdir}/afni_src
+
+ if [[ "$CARCH" == 'i686' ]]; then
+ sed -i 's^-m64^-m32^g' Makefile
+ fi
+
+ MAKEFLAGS="" CPPFLAGS="" make
+}
+
+package(){
+ mkdir -p $pkgdir/opt
+ cp -r $srcdir/build $pkgdir/opt/afni
+ find $pkgdir/opt/afni -name \*.a -delete
+ find $pkgdir/opt/afni -name \*.h -delete
+
+ mkdir -p $pkgdir/usr/share/licenses/afni
+ cp $srcdir/afni_src/README.copyright $pkgdir/usr/share/licenses/afni/LICENSE
+}