summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Oechsle2018-11-01 15:27:12 +0100
committerSebastian Oechsle2018-11-01 15:27:12 +0100
commit57ab8c5cbc2207fcfdda7d464504b28eff5ae057 (patch)
tree939cf4d7ea8c630d9dc2d9a3850643d9a90c6fb7
downloadaur-57ab8c5cbc2207fcfdda7d464504b28eff5ae057.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63f33f9d666f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = afpfsng_git
+ pkgdesc = Fork of afpfs-ng that adds IPv6 support and several performance and stability improvements.
+ pkgver = f6e24eb
+ pkgrel = 1
+ url = https://github.com/simonvetter/afpfs-ng
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = fuse3
+ depends = libgcrypt
+ provides = afpfs-ng
+ conflicts = afpfs-ng
+ source = git+https://github.com/simonvetter/afpfs-ng.git
+ md5sums = SKIP
+
+pkgname = afpfsng_git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58611d6846f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Sebastian Oechsle <setboolean@icloud.com>
+pkgname=afpfsng_git
+pkgver=f6e24eb
+pkgrel=1
+pkgdesc="Fork of afpfs-ng that adds IPv6 support and several performance and stability improvements."
+arch=('x86_64')
+url="https://github.com/simonvetter/afpfs-ng"
+license=('GPL3')
+groups=()
+depends=('fuse3' 'libgcrypt')
+optdepends=()
+makedepends=('git')
+provides=("afpfs-ng")
+conflicts=("afpfs-ng")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/simonvetter/afpfs-ng.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/afpfs-ng"
+ git describe --always
+}
+
+build() {
+ cd "$srcdir/afpfs-ng"
+ ./configure
+ make
+}
+
+package() {
+ cd "$srcdir/afpfs-ng"
+ make DESTDIR="$pkgdir/" prefix="/usr/" install
+}
+