summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormar77i2016-06-05 12:05:55 +0200
committermar77i2016-06-05 12:05:55 +0200
commit0e2f01874d130007ff4e006ea9910efa9065c8ea (patch)
treec9440e136cf90f0374af19c12e49a2d4101705d5
downloadaur-0e2f01874d130007ff4e006ea9910efa9065c8ea.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--afraiddns-git.install8
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1235244e9f8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Jun 5 10:03:53 UTC 2016
+pkgbase = afraiddns-git
+ pkgdesc = Service to update a subdomain reserved through afraid.org.
+ pkgver = 0
+ pkgrel = 1
+ url = https://github.com/mar77i/afraiddns
+ install = afraiddns-git.install
+ arch = any
+ license = ISC
+ depends = curl
+ source = git+https://github.com/mar77i/afraiddns
+ sha1sums = SKIP
+
+pkgname = afraiddns-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13539b29fead
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=afraiddns-git
+pkgver=0
+pkgrel=1
+pkgdesc="Service to update a subdomain reserved through afraid.org."
+url="https://github.com/mar77i/afraiddns"
+arch=(any)
+license=('ISC')
+depends=('curl')
+install="${pkgname}.install"
+source=("git+https://github.com/mar77i/afraiddns")
+sha1sums=(SKIP)
+
+build() {
+ :
+}
+
+package() {
+ cd "$srcdir/afraiddns"
+ install -m644 -D "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -m644 -D "afraiddns.service" \
+ "${pkgdir}/usr/lib/systemd/system/afraiddns.service"
+ install -m644 -D "afraiddns.timer" \
+ "${pkgdir}/usr/lib/systemd/system/afraiddns.timer"
+ install -m755 -D "afraiddns" "${pkgdir}/usr/bin/afraiddns"
+}
diff --git a/afraiddns-git.install b/afraiddns-git.install
new file mode 100644
index 000000000000..ad9eeb1ae05e
--- /dev/null
+++ b/afraiddns-git.install
@@ -0,0 +1,8 @@
+post_install() {
+ if [[ ! -e "/etc/afraiddns/apikey" ]]; then
+ mkdir -p "/etc/afraiddns"
+ touch "/etc/afraiddns/apikey"
+ fi
+ echo "Please provide the API secret key you receive from afraid.org"
+ echo "in /etc/afraiddns/apikey "
+}