summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarenome Ranaivoarivony-Razanajato2019-02-06 20:16:29 +0100
committerHarenome Ranaivoarivony-Razanajato2019-02-06 20:17:34 +0100
commit860f2a28604ad1c1b66a66d9086c20ef8ebb26be (patch)
tree0a8e7e1f1ba6974b3e251c018ae56d37f3cdc492
downloadaur-860f2a28604ad1c1b66a66d9086c20ef8ebb26be.tar.gz
aftermath r624.17ed7ce
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
-rw-r--r--python2.patch69
3 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..049515faa361
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = aftermath-git
+ pkgdesc = Afetermath: Trace-based performance analysis for OpenMP and OpenStream
+ pkgver = r624.17ed7ce
+ pkgrel = 1
+ url = https://aftermath-tracing.com/
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ license = FDL1.3
+ makedepends = python2-numpy
+ depends = libglade
+ provides = aftermath
+ source = aftermath-git::git://git.drebesium.org/aftermath.git#branch=staging
+ source = python2.patch
+ md5sums = SKIP
+ md5sums = 2a77fafa1220f68da5e879a737677264
+
+pkgname = aftermath-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6861f43f1e64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Harenome Ranaivoarivony-Razanajato <ranaivoarivony-razanajato@hareno.me>
+
+pkgname=aftermath-git
+pkgver=r624.17ed7ce
+pkgrel=1
+pkgdesc="Afetermath: Trace-based performance analysis for OpenMP and OpenStream"
+arch=('x86_64')
+url="https://aftermath-tracing.com/"
+license=('GPL2' 'LGPL2.1' 'FDL1.3')
+depends=("libglade")
+makedepends=("python2-numpy")
+provides=("aftermath")
+source=(
+ ${pkgname}::git://git.drebesium.org/aftermath.git#branch=staging
+ python2.patch
+)
+md5sums=(
+ 'SKIP'
+ '2a77fafa1220f68da5e879a737677264'
+)
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git apply "${srcdir}/python2.patch"
+}
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ # We use the number of commits and the last commit hash because:
+ # - the repository has no tag.
+ # - there is no reference to a version number in the source code.
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ # We run this twice because of an error with automake.
+ autoreconf -fi || autoreconf -fi
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}/" install
+}
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..a4c62634156b
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,69 @@
+diff --git a/Makefile.am b/Makefile.am
+index 36cddaf..4f5ecd3 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -354,7 +354,7 @@ tests/wr_trace2core.test.c: ./tests/auto/scripts/rwspec.py \
+ ./tests/auto/read-write/states.rwspec \
+ ./tests/auto/read-write/counters.rwspec \
+ ./tests/auto/read-write/measurement_intervals.rwspec
+- python $(srcdir)/tests/auto/scripts/rwspec.py -o $@ $(filter %.rwspec,$^)
++ python2 $(srcdir)/tests/auto/scripts/rwspec.py -o $@ $(filter %.rwspec,$^)
+
+ wr_trace2core_test_SOURCES = tests/wr_trace2core.test.c \
+ $(UNIT_TEST_SOURCES)
+diff --git a/configure.ac b/configure.ac
+index 2cb03b8..e8d1da9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -93,7 +93,7 @@ PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.0])
+ PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.0])
+ PKG_CHECK_MODULES(GLADE, [libglade-2.0 >= 2.0])
+
+-CHECK_CUSTOM_PROG(python)
++CHECK_CUSTOM_PROG(python2)
+ AC_PYTHON_MODULE(sets, true)
+ AC_PYTHON_MODULE(sys, true)
+ AC_PYTHON_MODULE(shlex, true)
+diff --git a/m4/python.m4 b/m4/python.m4
+index 58686a0..03c9175 100644
+--- a/m4/python.m4
++++ b/m4/python.m4
+@@ -2,7 +2,7 @@
+
+ AC_DEFUN([AC_PYTHON_MODULE],[
+ AC_MSG_CHECKING(python module: $1)
+- python -c "import $1" 2> /dev/null
++ python2 -c "import $1" 2> /dev/null
+ if test $? -eq 0;
+ then
+ AC_MSG_RESULT(yes)
+diff --git a/tests/auto/scripts/rwspec.py b/tests/auto/scripts/rwspec.py
+index eb88706..497dcf4 100755
+--- a/tests/auto/scripts/rwspec.py
++++ b/tests/auto/scripts/rwspec.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # -*- coding: utf-8 -*-
+
+ # Copyright (C) 2016 Andi Drebes <andi.drebes@lip6.fr>
+diff --git a/tests/auto/scripts/rwspec_defs.py b/tests/auto/scripts/rwspec_defs.py
+index c2a4777..4a3af09 100644
+--- a/tests/auto/scripts/rwspec_defs.py
++++ b/tests/auto/scripts/rwspec_defs.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # -*- coding: utf-8 -*-
+
+ # Copyright (C) 2016 Andi Drebes <andi.drebes@lip6.fr>
+diff --git a/tests/auto/scripts/rwspec_helpers.py b/tests/auto/scripts/rwspec_helpers.py
+index 9744f9a..018ad71 100644
+--- a/tests/auto/scripts/rwspec_helpers.py
++++ b/tests/auto/scripts/rwspec_helpers.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # -*- coding: utf-8 -*-
+
+ # Copyright (C) 2016 Andi Drebes <andi.drebes@lip6.fr>