summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2022-12-17 04:49:51 +0000
committerBioArchLinuxBot2022-12-17 04:49:51 +0000
commit9a07db70dfe2ee8f2d4d389311a28e614a8eb321 (patch)
tree6e4c77b3e635828a869ceb9fd1cbf6a10c45f547
parent7714fdb1d5114e24a629a49fff8907a550ac502a (diff)
downloadaur-9a07db70dfe2ee8f2d4d389311a28e614a8eb321.tar.gz
[lilac] updated to 1.0.0-3
-rw-r--r--.SRCINFO16
-rw-r--r--[-rwxr-xr-x]PKGBUILD28
2 files changed, 31 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cec292136e98..0522663dd400 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
pkgbase = agat
- pkgdesc = Another Gtf/Gff Analysis Toolkit: Suite of tools to handle gene annotations in any GTF/GFF format. https://www.doi.org/10.5281/zenodo.3552717
+ pkgdesc = Another Gtf/Gff Analysis Toolkit is a suite of tools to handle gene annotations in GTF/GFF format. doi:10.5281/zenodo.3552717
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/NBISweden/AGAT
arch = any
license = GPL3
depends = perl-bioperl
- depends = perl-clone
depends = perl-carp-clan
- depends = perl-sort-naturally
- depends = perl-yaml-libyaml
- depends = perl-lwp-protocol-https
+ depends = perl-clone
+ depends = perl-file-share
depends = perl-file-sharedir
depends = perl-file-sharedir-install
depends = perl-graph
+ depends = perl-lwp-protocol-https
depends = perl-lwp-useragent-determined
depends = perl-moose
- depends = perl-file-share
+ depends = perl-sort-naturally
+ depends = perl-yaml-libyaml
+ options = !emptydirs
+ options = purge
source = agat-1.0.0.tar.gz::https://github.com/NBISweden/AGAT/archive/refs/tags/v1.0.0.tar.gz
sha512sums = 937b03f5f76afe0a190760046ab05f3c91b7a4582d2cde0053479659e7da460221d7051bd307e06239e5b5786f050eb7492ca4cc8744f022254ab9e3eb49c45a
diff --git a/PKGBUILD b/PKGBUILD
index 9a33f62a20e3..cb2f4f42ae21 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,45 @@
pkgname=agat
_pkgname=AGAT
pkgver=1.0.0
-pkgrel=1
-pkgdesc="Another Gtf/Gff Analysis Toolkit: Suite of tools to handle gene annotations in any GTF/GFF format. https://www.doi.org/10.5281/zenodo.3552717"
+pkgrel=3
+pkgdesc="Another Gtf/Gff Analysis Toolkit is a suite of tools to handle gene annotations in GTF/GFF format. doi:10.5281/zenodo.3552717"
arch=('any')
-license=('GPL3')
-depends=('perl-bioperl' 'perl-clone' 'perl-carp-clan' 'perl-sort-naturally' 'perl-yaml-libyaml' 'perl-lwp-protocol-https' 'perl-file-sharedir' 'perl-file-sharedir-install' 'perl-graph' 'perl-lwp-useragent-determined' 'perl-moose' 'perl-file-share')
url='https://github.com/NBISweden/AGAT'
+license=('GPL3')
+depends=(
+ 'perl-bioperl'
+ 'perl-carp-clan'
+ 'perl-clone'
+ 'perl-file-share'
+ 'perl-file-sharedir'
+ 'perl-file-sharedir-install'
+ 'perl-graph'
+ 'perl-lwp-protocol-https'
+ 'perl-lwp-useragent-determined'
+ 'perl-moose'
+ 'perl-sort-naturally'
+ 'perl-yaml-libyaml'
+ )
source=($pkgname-$pkgver.tar.gz::https://github.com/NBISweden/AGAT/archive/refs/tags/v$pkgver.tar.gz)
sha512sums=('937b03f5f76afe0a190760046ab05f3c91b7a4582d2cde0053479659e7da460221d7051bd307e06239e5b5786f050eb7492ca4cc8744f022254ab9e3eb49c45a')
+options=('!emptydirs' 'purge')
prepare() {
- cd $_pkgname-$pkgver
+ cd $_pkgname-$pkgver
sed -i '51d' Makefile.PL #remove unneeded json dependency from makefile
}
build() {
cd $_pkgname-$pkgver
perl Makefile.PL INSTALLDIRS=vendor
+
make PREFIX="$pkgdir"/usr INSTALLDIR=${pkgdir}/usr/bin
}
package() {
cd $_pkgname-$pkgver
- install -d "$pkgdir"/usr/bin/vendor_perl
+ install -dm755 "$pkgdir"/usr/bin/vendor_perl
+
make install DESTDIR="$pkgdir"
find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}