summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commit91939558408c522c7b01fa40cdd7bfe2bff23468 (patch)
tree9c5e86426be90109f71728d5545f3088cdf2fb41
downloadaur-agave.tar.gz
Move from [community] to AUR in connection with the spring cleaning
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD55
-rw-r--r--agave-0.4.7-mdv-fix-str-fmt.patch12
-rw-r--r--drop-libgnome.patch66
-rw-r--r--fix-build-without-gconf.patch55
-rw-r--r--schemebox.patch11
6 files changed, 225 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b692b100bc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 09:15:56 UTC 2019
+pkgbase = agave
+ pkgdesc = Colorscheme designer tool for GNOME
+ pkgver = 0.4.7
+ pkgrel = 10
+ url = https://web.archive.org/web/20170327063642/http://home.gna.org/colorscheme/
+ arch = x86_64
+ license = GPL
+ makedepends = gnome-doc-utils
+ makedepends = intltool
+ makedepends = boost
+ depends = libglademm
+ source = http://ftp.debian.org/debian/pool/main/a/agave/agave_0.4.7.orig.tar.gz
+ source = agave-0.4.7-mdv-fix-str-fmt.patch
+ source = schemebox.patch
+ source = drop-libgnome.patch
+ source = fix-build-without-gconf.patch
+ sha256sums = 4005361ab1b137029c7d50afbbfbae7d83bdde7cec3e155a85eed59f6ec4e6fc
+ sha256sums = 132008f0bbe040c59bbc134d9ca3eb244967a66f95bf113d94e976b8ed776c6c
+ sha256sums = 0471ac9d7057f83d3fc667d7387837a2d85cb0d15a58853dd673a6ea1459623c
+ sha256sums = 8651250047b5882b00d28ac6d7ff587f53f99bd681c201545b6cf25c5acaaac6
+ sha256sums = 225f9a5cfebea4f9c1d4120611394eb148ffb9a6c151e79f749df1749e015c91
+
+pkgname = agave
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cad2d23c8be9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer:
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
+# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgname=agave
+pkgver=0.4.7
+pkgrel=10
+pkgdesc="Colorscheme designer tool for GNOME"
+arch=('x86_64')
+url="https://web.archive.org/web/20170327063642/http://home.gna.org/colorscheme/"
+license=('GPL')
+depends=('libglademm')
+makedepends=('gnome-doc-utils' 'intltool' 'boost')
+source=(http://ftp.debian.org/debian/pool/main/a/$pkgname/${pkgname}_$pkgver.orig.tar.gz
+ agave-0.4.7-mdv-fix-str-fmt.patch
+ schemebox.patch
+ drop-libgnome.patch
+ fix-build-without-gconf.patch)
+sha256sums=('4005361ab1b137029c7d50afbbfbae7d83bdde7cec3e155a85eed59f6ec4e6fc'
+ '132008f0bbe040c59bbc134d9ca3eb244967a66f95bf113d94e976b8ed776c6c'
+ '0471ac9d7057f83d3fc667d7387837a2d85cb0d15a58853dd673a6ea1459623c'
+ '8651250047b5882b00d28ac6d7ff587f53f99bd681c201545b6cf25c5acaaac6'
+ '225f9a5cfebea4f9c1d4120611394eb148ffb9a6c151e79f749df1749e015c91')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # Build fix from Fedora
+ patch -Np1 -i ../agave-0.4.7-mdv-fix-str-fmt.patch
+
+ # Another build fix
+ patch -Np1 -i ../schemebox.patch
+
+ # Remove deprecated libgnome dependency
+ patch -Np1 -i ../drop-libgnome.patch
+
+ # Fix build without gconfmm installed
+ patch -Np1 -i ../fix-build-without-gconf.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ CXXFLAGS+=' -std=c++11'
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-scrollkeeper --disable-gnome --disable-gconf
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir/agave.schemas"
+}
diff --git a/agave-0.4.7-mdv-fix-str-fmt.patch b/agave-0.4.7-mdv-fix-str-fmt.patch
new file mode 100644
index 000000000000..7487a0c4d5d5
--- /dev/null
+++ b/agave-0.4.7-mdv-fix-str-fmt.patch
@@ -0,0 +1,12 @@
+diff -p -up agave-0.4.7/src/dialogs/gcs-about-window.cc.strfmt agave-0.4.7/src/dialogs/gcs-about-window.cc
+--- agave-0.4.7/src/dialogs/gcs-about-window.cc.strfmt 2009-11-25 15:00:03.000000000 +0100
++++ agave-0.4.7/src/dialogs/gcs-about-window.cc 2009-11-25 15:31:43.000000000 +0100
+@@ -105,7 +105,7 @@ namespace gcs
+ catch (const Glib::Error& e)
+ {
+ Glib::ustring message = "Couldn't load Agave logo image from theme. " + e.what();
+- g_warning(message.c_str());
++ g_warning("%s", message.c_str());
+ }
+ }
+ }
diff --git a/drop-libgnome.patch b/drop-libgnome.patch
new file mode 100644
index 000000000000..5dd704e34354
--- /dev/null
+++ b/drop-libgnome.patch
@@ -0,0 +1,66 @@
+diff -Naur agave-0.4.4.orig/src/dialogs/gcs-about-window.cc agave-0.4.4/src/dialogs/gcs-about-window.cc
+--- agave-0.4.4.orig/src/dialogs/gcs-about-window.cc 2007-11-02 04:16:16.000000000 +0100
++++ agave-0.4.4/src/dialogs/gcs-about-window.cc 2012-03-20 22:01:55.835021376 +0100
+@@ -26,9 +26,6 @@
+ #include <cstring> // for strlen()
+
+ #include <config.h>
+-#ifdef HAVE_GNOME
+-#include <libgnome/gnome-url.h>
+-#endif // HAVE_GNOME
+
+ #include <gtkmm/icontheme.h>
+
+@@ -46,11 +43,8 @@
+ {
+ set_name(PACKAGE_NAME);
+
+-#ifdef HAVE_GNOME
+- set_url_hook(sigc::mem_fun(*this, &AboutWindow::on_link_clicked));
+ set_website(PACKAGE_WEBSITE);
+ set_website_label(_("Project Website"));
+-#endif // HAVE_GNOME
+
+ Glib::ustring version(PACKAGE_VERSION);
+ set_version(version);
+@@ -112,15 +106,6 @@
+
+
+ void
+- AboutWindow::on_link_clicked(Gtk::AboutDialog& dialog,
+- const Glib::ustring& link)
+- {
+-#ifdef HAVE_GNOME
+- gnome_url_show(link.c_str(), 0);
+-#endif // HAVE_GNOME
+- }
+-
+- void
+ AboutWindow::on_response(int response_id)
+ {
+ if (response_id == Gtk::RESPONSE_DELETE_EVENT ||
+diff -Naur agave-0.4.4.orig/src/gcs-mainwindow-actions.cc agave-0.4.4/src/gcs-mainwindow-actions.cc
+--- agave-0.4.4.orig/src/gcs-mainwindow-actions.cc 2007-11-02 04:01:16.000000000 +0100
++++ agave-0.4.4/src/gcs-mainwindow-actions.cc 2012-03-20 22:01:10.637760066 +0100
+@@ -25,7 +25,6 @@
+
+ #include <vector>
+ #include <gtk/gtk.h>
+-#include <libgnome/gnome-help.h>
+ #include <gtkmm/iconfactory.h>
+ #include <gtkmm/stock.h>
+ #include <gtkmm/clipboard.h>
+@@ -251,9 +250,10 @@
+ /* Help Menu Actions */
+ void MainWindow::on_action_help_contents(void)
+ {
+- gnome_help_display("agave.xml",
+- NULL /* link id */,
+- NULL /* GError */);
++ gtk_show_uri (NULL,
++ "ghelp:agave",
++ gtk_get_current_event_time (),
++ NULL);
+ }
+
+
diff --git a/fix-build-without-gconf.patch b/fix-build-without-gconf.patch
new file mode 100644
index 000000000000..f8735a3aced1
--- /dev/null
+++ b/fix-build-without-gconf.patch
@@ -0,0 +1,55 @@
+diff -Naur agave-0.4.7.orig/src/gcs-conf.cc agave-0.4.7/src/gcs-conf.cc
+--- agave-0.4.7.orig/src/gcs-conf.cc 2008-02-26 04:07:02.000000000 +0100
++++ agave-0.4.7/src/gcs-conf.cc 2018-09-05 13:00:23.733940123 +0200
+@@ -26,6 +26,7 @@
+ #include "config.h"
+ #include "gcs-conf.h"
+ #include "core/gcs-color.h"
++#include <glibmm.h>
+ #ifdef HAVE_GCONFMM
+ #include <gconfmm/client.h>
+ #include <gconfmm/value.h>
+@@ -36,6 +37,7 @@
+ // gconf recommends storing enumerations as strings rather than integers
+ // since it's more robust against changes in enumeration order and is more
+ // human-readable. This is a helper for gconf_string_to_enum and vice versa
++#ifdef HAVE_GCONFMM
+ static GConfEnumStringPair schemetype_lookup_table[] =
+ {
+ { SCHEME_COMPLEMENTS, "COMPLEMENTS" },
+@@ -59,6 +61,7 @@
+ operator double() { return get_float(); }
+ operator float() { return get_float(); }
+ };
++#endif // HAVE_GCONFMM
+
+ const Glib::ustring Conf::APP_DIR = "/apps/agave";
+
+@@ -128,8 +131,10 @@
+
+ void Conf::set_last_scheme_type(tSchemeType t)
+ {
++#ifdef HAVE_GCONFMM
+ Glib::ustring schemetype_string = gconf_enum_to_string(schemetype_lookup_table, t);
+ set_value(KEY_LAST_SCHEME_TYPE, schemetype_string);
++#endif // HAVE_GCONFMM
+ }
+
+
+@@ -137,12 +142,16 @@
+ {
+ Glib::ustring scheme_type;
+ tSchemeType t;
++#ifdef HAVE_GCONFMM
+ if (!get_value(KEY_LAST_SCHEME_TYPE, scheme_type) ||
+ !gconf_string_to_enum(schemetype_lookup_table,
+ scheme_type.c_str(), reinterpret_cast<int*>(&t)))
+ {
++#endif // HAVE_GCONFMM
+ t = SCHEME_TRIADS;
++#ifdef HAVE_GCONFMM
+ }
++#endif // HAVE_GCONFMM
+ return t;
+ }
+
diff --git a/schemebox.patch b/schemebox.patch
new file mode 100644
index 000000000000..c00a867dedf5
--- /dev/null
+++ b/schemebox.patch
@@ -0,0 +1,11 @@
+--- agave-0.4.7/src/widgets/gcs-schemebox.cc 2008-02-25 21:07:02.000000000 -0600
++++ agave-0.4.7/src/widgets/gcs-schemebox.cc.new 2010-05-24 00:28:51.000000000 -0500
+@@ -45,7 +45,7 @@ namespace gcs
+
+ SchemeBox::SchemeBox(Scheme schm)
+ {
+- SchemeBox::SchemeBox();
++ SchemeBox();
+ set_scheme(schm);
+ }
+