summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Nicholi2020-10-15 06:17:15 -0400
committerAlexander Nicholi2020-10-15 06:17:15 -0400
commit72e690af2c14834d5c3e84186064ca22d0981005 (patch)
treec65e0559a1f88e0747a04acbdc6295587a3aef18
downloadaur-72e690af2c14834d5c3e84186064ca22d0981005.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dafb71e938d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = agb-armv4t-eabi-unilib
+ pkgdesc = unilib, the ANSI C support library (GBA)
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/aquefir/agb-armv4t-eabi-unilib
+ arch = any
+ license = BSD
+ makedepends = slick>=1.1.0
+ provides = agb-armv4t-eabi-unilib
+ conflicts = agb-armv4t-eabi-unilib
+ source = https://github.com/aquefir/unilib/archive/v1.1.0-1.2.1.tar.gz
+ sha1sums = SKIP
+
+pkgname = agb-armv4t-eabi-unilib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c1e87aa3507
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Alexander Nicholi <me@nicholatian.com>
+pkgname=agb-armv4t-eabi-unilib
+pkgver=1.2.1
+pkgrel=1
+epoch=
+pkgdesc='unilib, the ANSI C support library (GBA)'
+arch=('any')
+url="https://github.com/aquefir/$pkgname"
+license=('BSD')
+depends=()
+makedepends=('slick>=1.1.0')
+provides=("$pkgname")
+conflicts=("$pkgname")
+_symver=1.1.0
+source=("https://github.com/aquefir/${pkgname#agb-armv4t-eabi-}/archive/v${_symver}-$pkgver.tar.gz")
+sha1sums=('SKIP')
+
+_subprojects='arr chkmath decl endian err himem log str'
+
+build() {
+ cd "$srcdir/${pkgname#agb-armv4t-eabi-}-${_symver}-$pkgver"
+ # install log headers for err circular dependency
+ #cd log
+ #make install PREFIX="${pkgdir}/usr/agb-armv4t-eabi" TP=GBA
+ #cd ..
+ for _subproj in ${_subprojects}; do
+ cd "${_subproj}"
+ make -j$(($(nproc) * 2)) release TP=GBA
+ cd ..
+ done
+}
+
+package() {
+ cd "$srcdir/${pkgname#agb-armv4t-eabi-}-${_symver}-$pkgver"
+
+ cd log
+ make -i install PREFIX="${pkgdir}/usr/agb-armv4t-eabi" TP=GBA
+ cd ..
+ for _subproj in ${_subprojects}; do
+ cd "${_subproj}"
+ make install PREFIX="${pkgdir}/usr/agb-armv4t-eabi" TP=GBA
+ cd ..
+ done
+}