summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTharre2021-03-20 02:55:57 +0100
committerTharre2021-03-20 02:55:57 +0100
commit82fecb700124700a90756ae6763bef4e86b40999 (patch)
treebb770884a75ef6739ec4cb77ca17a914b7029b15
parent99e245759c7e2c3c9e1324c6d9ac2f48b8a68476 (diff)
downloadaur-82fecb700124700a90756ae6763bef4e86b40999.tar.gz
Remove preloading via `go mod download`
There seems to be no way of providing `-modcacherw` or something equivalent to `go mod download`, resulting in the option to be ignored later in `go build`. This causes the mod files in src/ to be read-only, which is not ideal. Since the benefits of preloading are contested anyway, we default to the simplest solution and remove it for now.
-rw-r--r--PKGBUILD8
1 files changed, 0 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c0f8d7295f1..3d52532886db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,15 +13,8 @@ makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$_pkgver.tar.gz")
sha256sums=('2ef0839b0e2e79435c037662c67df675b4ebc50d7bf001079d24b0bdf1d0c098')
-prepare() {
- cd "$pkgname-$_pkgver"
- export GOPATH="$srcdir"
- go mod download
-}
-
build() {
cd "$pkgname-$_pkgver"
- export GOPATH="$srcdir"
go build \
-trimpath \
-buildmode=pie \
@@ -33,7 +26,6 @@ build() {
check() {
cd "$pkgname-$_pkgver"
- export GOPATH="$srcdir"
go test ./...
}