summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2019-10-07 14:34:36 +1100
committerStephen Gregoratto2019-10-07 14:34:36 +1100
commit1e91b9352e8f292b1290b523a3e4e5ba79b2af22 (patch)
treee9587350c388ac571856cf0e924ebc6b849e2c82
downloadaur-1e91b9352e8f292b1290b523a3e4e5ba79b2af22.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dded6f94b234
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = age-git
+ pkgdesc = A simple and secure encryption based on UNIX-style composability.
+ pkgver = r5.0940f18
+ pkgrel = 1
+ url = https://github.com/FiloSottile/age
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = custom: BSD
+ makedepends = go-pie
+ makedepends = git
+ provides = age
+ source = age::git+https://github.com/FiloSottile/age
+ sha256sums = SKIP
+
+pkgname = age-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..142d7e5bd75a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: KingofToasters <dev at sgregoratto dot me>
+pkgname=age-git
+pkgver=r5.0940f18
+pkgrel=1
+pkgdesc="A simple and secure encryption based on UNIX-style composability."
+url="https://github.com/FiloSottile/age"
+license=('custom: BSD')
+provides=('age')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+makedepends=('go-pie' 'git')
+source=("${pkgname%-git}::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${pkgname%-git}/cmd/age"
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o "${pkgname%-git}" .
+}
+
+check() {
+ cd "${pkgname%-git}"
+ go test ./...
+}
+
+package() {
+ install -Dm755 "${pkgname%-git}/cmd/age/age" "${pkgdir}/usr/bin/${pkgname%-git}/age"
+ install -Dm644 "${pkgname%-git}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENCE"
+}