summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2020-06-02 12:40:33 +1000
committerStephen Gregoratto2020-06-02 12:44:10 +1000
commitb16b0c98ed3a6af5f6a308151bc6964cc21fdc42 (patch)
tree69a7b847798c15d64d62cdadf4eaecd8fa536181
parentd2d7f15aed0dd60ff00dcbc5d45fd8437d68b3d9 (diff)
downloadaur-b16b0c98ed3a6af5f6a308151bc6964cc21fdc42.tar.gz
actually fix pkgver, change license
Also add MVP Caleb as a contributor.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e592e4f0389..04567a5a7b47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = age-git
pkgdesc = A simple, modern and secure file encryption tool
- pkgver = v1.0.0.beta2.r35.gc9a35c0
- pkgrel = 2
+ pkgver = 1.0.0.beta2.r35.gc9a35c0
+ pkgrel = 1
url = https://github.com/FiloSottile/age
arch = i686
arch = x86_64
arch = armv6h
arch = armv7h
- license = custom: BSD
+ license = BSD
makedepends = go
makedepends = git
depends = glibc
diff --git a/PKGBUILD b/PKGBUILD
index a481fb89a331..d81e881be668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Stephen Gregoratto <dev@sgregoratto.me>
+# Contributor: Caleb Maclennan <caleb@alerque.com>
pkgname=age-git
-pkgver=v1.0.0.beta2.r35.gc9a35c0
-pkgrel=2
+pkgver=1.0.0.beta2.r35.gc9a35c0
+pkgrel=1
pkgdesc="A simple, modern and secure file encryption tool"
url="https://github.com/FiloSottile/age"
-license=('custom: BSD')
+license=('BSD')
provides=('age')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
depends=('glibc')
@@ -19,10 +20,7 @@ prepare(){
pkgver() {
cd "${pkgname%-git}"
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {