summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorferion2017-07-19 20:57:38 +0300
committerferion2017-07-19 20:57:38 +0300
commite4380d7ccfee1f8235ad3e84874d5147914bfb9f (patch)
tree587282ac7274652c36ffce572e3bb411670321a6
downloadaur-e4380d7ccfee1f8235ad3e84874d5147914bfb9f.tar.gz
Initial package commit
-rw-r--r--.SRCINFO51
-rw-r--r--PKGBUILD97
-rw-r--r--agensgraph.patch10
-rw-r--r--agensgraph.service26
-rw-r--r--postgresql-check-db-dir49
-rw-r--r--postgresql-run-socket.patch12
-rw-r--r--postgresql.install39
-rw-r--r--postgresql.logrotate4
-rw-r--r--postgresql.pam3
-rw-r--r--postgresql.tmpfiles.conf1
10 files changed, 292 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..634038d45eae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+pkgbase = agensgraph-git
+ pkgdesc = A multi-model graph database based on PostgreSQL.
+ pkgver = 1.1.0.r41.gaf9b283
+ pkgrel = 1
+ url = http://bitnine.net/agensgraph/
+ install = postgresql.install
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = tcl
+ makedepends = jdk
+ depends = libxml2
+ depends = readline
+ depends = zlib
+ depends = openssl
+ depends = krb5
+ depends = python2
+ depends = perl
+ optdepends = python2: for PL/Python support
+ optdepends = perl: for PL/Perl support
+ optdepends = tcl: for PL/Tcl support
+ provides = postgresql-libs=9.6.2
+ provides = postgresql=9.6.2
+ provides = postgresql-client
+ conflicts = postgresql
+ conflicts = postgresql-libs
+ conflicts = postgresql-testing
+ conflicts = postgresql-client
+ conflicts = postgresql-git
+ options = !strip
+ backup = etc/pam.d/postgresql
+ backup = etc/logrotate.d/postgresql
+ source = git+https://github.com/bitnine-oss/agensgraph
+ source = postgresql-run-socket.patch
+ source = agensgraph.patch
+ source = postgresql.pam
+ source = postgresql.logrotate
+ source = agensgraph.service
+ source = postgresql.tmpfiles.conf
+ source = postgresql-check-db-dir
+ sha256sums = SKIP
+ sha256sums = 8538619cb8bea51078b605ad64fe22abd6050373c7ae3ad6595178da52f6a7d9
+ sha256sums = 0cfec996d06aa83d0ddd08d0ced3ebc9187d26fd05f90d54788a85bf6b7bd7b3
+ sha256sums = 57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5
+ sha256sums = 6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e
+ sha256sums = daab6220ef01c729574384a3095f0659bf25617d6c195248a0cd28ede9b6c054
+ sha256sums = 7e086d70e0dcaa6ce45693b4e826ce92d770192b3aff5642319b1ef279d88dc4
+ sha256sums = 40da687da4fb1f6b35f406dd0f48922065d8c905d678e2a27da05806f874b780
+
+pkgname = agensgraph-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..454ef9e20238
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,97 @@
+# Maintainer: ferion <ferion@bit0.ro>
+
+_pkgname='agensgraph'
+pkgname="${_pkgname}-git"
+pkgver=1.1.0.r41.gaf9b283
+pkgrel=1
+pkgdesc="A multi-model graph database based on PostgreSQL."
+arch=('i686' 'x86_64')
+url="http://bitnine.net/agensgraph/"
+depends=('libxml2' 'readline' 'zlib' 'openssl' 'krb5' 'python2' 'perl')
+backup=('etc/pam.d/postgresql' 'etc/logrotate.d/postgresql')
+options=(!strip) # to facilitate debugging of testing builds
+license=('Apache')
+conflicts=('postgresql' 'postgresql-libs' 'postgresql-testing' 'postgresql-client' 'postgresql-git')
+makedepends=('tcl' 'jdk' )
+provides=("postgresql-libs=9.6.2" "postgresql=9.6.2" 'postgresql-client')
+optdepends=('python2: for PL/Python support'
+ 'perl: for PL/Perl support'
+ 'tcl: for PL/Tcl support')
+source=("git+https://github.com/bitnine-oss/agensgraph"
+ postgresql-run-socket.patch
+ agensgraph.patch
+ postgresql.pam
+ postgresql.logrotate
+ agensgraph.service
+ postgresql.tmpfiles.conf
+ postgresql-check-db-dir)
+install=postgresql.install
+sha256sums=('SKIP'
+ '8538619cb8bea51078b605ad64fe22abd6050373c7ae3ad6595178da52f6a7d9'
+ '0cfec996d06aa83d0ddd08d0ced3ebc9187d26fd05f90d54788a85bf6b7bd7b3'
+ '57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
+ '6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e'
+ 'daab6220ef01c729574384a3095f0659bf25617d6c195248a0cd28ede9b6c054'
+ '7e086d70e0dcaa6ce45693b4e826ce92d770192b3aff5642319b1ef279d88dc4'
+ '40da687da4fb1f6b35f406dd0f48922065d8c905d678e2a27da05806f874b780')
+pkgver() {
+ set -u
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed -e 's/^v//g' -e 's/\([^-]*-g\)/r\1/' -e 's/-/./g'
+ set +u
+}
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ patch -Np1 < ../postgresql-run-socket.patch
+ patch -Np1 < ../agensgraph.patch
+ export JAVA_LIBRARY_PATH="/usr/lib/jvm/default-runtime/lib/amd64/server"
+}
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/postgresql \
+ --sysconfdir=/etc \
+ --with-gssapi \
+ --with-libxml \
+ --with-perl \
+ --with-openssl \
+ --with-python PYTHON=/usr/bin/python2 \
+ --with-tcl \
+ --with-pam \
+ --with-uuid=e2fs \
+ --with-system-tzdata=/usr/share/zoneinfo \
+ --enable-nls \
+ --enable-thread-safety
+
+ make
+ make -C contrib
+}
+
+package() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ # install license
+ install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ make DESTDIR="${pkgdir}" install
+ make -C contrib DESTDIR="${pkgdir}" install
+
+ install -D -m755 "${srcdir}/HadoopJDBCLoader.class" \
+ "${pkgdir}/usr/lib/postgresql/HadoopJDBCLoader.class"
+ install -D -m755 "${srcdir}/HadoopJDBCUtils.class" \
+ "${pkgdir}/usr/lib/postgresql/HadoopJDBCUtils.class"
+ install -D -m644 "${srcdir}/postgresql.tmpfiles.conf" \
+ "${pkgdir}/usr/lib/tmpfiles.d/postgresql.conf"
+ install -D -m644 "${srcdir}/agensgraph.service" \
+ "${pkgdir}/usr/lib/systemd/system/agensgraph.service"
+ install -D -m755 "${srcdir}/postgresql-check-db-dir" \
+ "${pkgdir}/usr/bin/postgresql-check-db-dir"
+ install -D -m644 "${srcdir}/postgresql.pam" \
+ "${pkgdir}/etc/pam.d/postgresql"
+ install -D -m644 "${srcdir}/postgresql.logrotate" \
+ "${pkgdir}/etc/logrotate.d/postgresql"
+}
diff --git a/agensgraph.patch b/agensgraph.patch
new file mode 100644
index 000000000000..49a0714903fe
--- /dev/null
+++ b/agensgraph.patch
@@ -0,0 +1,10 @@
+--- agensgraph/contrib/hadoop_fdw/Makefile 2017-07-18 01:38:12.548453982 +0300
++++ agensgraph.new/contrib/hadoop_fdw/Makefile 2017-07-18 03:55:46.723320712 +0300
+@@ -33,7 +33,7 @@
+
+ PG_CPPFLAGS=-D'PKG_LIB_DIR=$(pkglibdir)'
+
+-JFLAGS = -d $(pkglibdir)
++JFLAGS = -d ../../../
+
+ all:$(TRGTS)
diff --git a/agensgraph.service b/agensgraph.service
new file mode 100644
index 000000000000..0dfddb171218
--- /dev/null
+++ b/agensgraph.service
@@ -0,0 +1,26 @@
+[Unit]
+Description=AgensGraph database server
+After=network.target
+
+[Service]
+Type=forking
+TimeoutSec=120
+User=postgres
+Group=postgres
+
+Environment=PGROOT=/var/lib/postgres
+
+SyslogIdentifier=postgres
+PIDFile=/var/lib/postgres/data/postmaster.pid
+
+ExecStartPre=/usr/bin/postgresql-check-db-dir ${PGROOT}/data
+ExecStart= /usr/bin/ag_ctl -s -D ${PGROOT}/data start -w -t 120
+ExecReload=/usr/bin/ag_ctl -s -D ${PGROOT}/data reload
+ExecStop= /usr/bin/ag_ctl -s -D ${PGROOT}/data stop -m fast
+
+# Due to PostgreSQL's use of shared memory, OOM killer is often overzealous in
+# killing Postgres, so adjust it downward
+OOMScoreAdjust=-200
+
+[Install]
+WantedBy=multi-user.target
diff --git a/postgresql-check-db-dir b/postgresql-check-db-dir
new file mode 100644
index 000000000000..bc706db5ab5d
--- /dev/null
+++ b/postgresql-check-db-dir
@@ -0,0 +1,49 @@
+#!/bin/sh
+
+# This script verifies that the postgresql data directory has been correctly
+# initialized. We do not want to automatically initdb it, because that has
+# a risk of catastrophic failure (ie, overwriting a valuable database) in
+# corner cases, such as a remotely mounted database on a volume that's a
+# bit slow to mount. But we can at least emit a message advising newbies
+# what to do.
+
+PGDATA="$1"
+
+if [ -z "$PGDATA" ]
+then
+ echo "Usage: $0 database-path"
+ exit 1
+fi
+
+# PGMAJORVERSION is major version
+PGMAJORVERSION=9.6
+# PREVMAJORVERSION is the previous major version, e.g., 8.4, for upgrades
+PREVMAJORVERSION=9.5
+
+# Check for the PGDATA structure
+if [ -f "$PGDATA/PG_VERSION" ] && [ -d "$PGDATA/base" ]
+then
+ # Check version of existing PGDATA
+ if [ x`cat "$PGDATA/PG_VERSION"` = x"$PGMAJORVERSION" ]
+ then
+ : A-OK
+ elif [ x`cat "$PGDATA/PG_VERSION"` = x"$PREVMAJORVERSION" ]
+ then
+ echo $"An old version of the database format was found."
+ echo $"See https://wiki.archlinux.org/index.php/PostgreSQL#Upgrading_PostgreSQL"
+ exit 1
+ else
+ echo $"An old version of the database format was found."
+ echo $"You need to dump and reload before using PostgreSQL $PGMAJORVERSION."
+ echo $"See http://www.postgresql.org/docs/$PGMAJORVERSION/static/upgrading.html"
+ exit 1
+ fi
+else
+ # No existing PGDATA! Warn the user to initdb it.
+ echo $"\"$PGDATA\" is missing or empty. Use a command like"
+ echo $" su - postgres -c \"initdb --locale en_US.UTF-8 -D '$PGDATA'\""
+ echo $"with relevant options, to initialize the database cluster."
+ exit 1
+fi
+
+exit 0
diff --git a/postgresql-run-socket.patch b/postgresql-run-socket.patch
new file mode 100644
index 000000000000..b558c7b74961
--- /dev/null
+++ b/postgresql-run-socket.patch
@@ -0,0 +1,12 @@
+diff -Naur postgresql-9.2.0.sockets/src/include/pg_config_manual.h postgresql-9.2.0/src/include/pg_config_manual.h
+--- postgresql-9.2.0.sockets/src/include/pg_config_manual.h 2012-09-06 17:26:17.000000000 -0400
++++ postgresql-9.2.0/src/include/pg_config_manual.h 2012-09-06 18:13:18.183092471 -0400
+@@ -144,7 +144,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
diff --git a/postgresql.install b/postgresql.install
new file mode 100644
index 000000000000..699efe692afd
--- /dev/null
+++ b/postgresql.install
@@ -0,0 +1,39 @@
+post_install() {
+ if [ ! -d '/var/lib/postgres' ]; then
+ mkdir -p '/var/lib/postgres'
+ fi
+ if ! getent group postgres >/dev/null; then
+ groupadd -g 88 postgres
+ fi
+ if ! getent passwd postgres >/dev/null; then
+ useradd -c 'PostgreSQL user' -u 88 -g postgres -d '/var/lib/postgres' -s /bin/bash postgres
+ passwd -l postgres >/dev/null
+ fi
+ systemd-tmpfiles --create postgresql.conf
+ if [ ! -d '/var/lib/postgres/data' ]; then
+ mkdir -p '/var/lib/postgres/data'
+ chown postgres:postgres '/var/lib/postgres/data'
+ fi
+}
+
+post_upgrade() {
+ post_install $1
+ # FS#23858, fix postgres user shell issue
+ postgres_shell=$(getent passwd postgres | cut -d: -f7)
+ if [ "$postgres_shell" = "/sbin/nologin" ]; then
+ chsh -s /bin/bash postgres
+ fi
+ if [ $(vercmp $2 '9.2.1-2') -lt 0 ]; then
+ echo "Note: The Unix domain socket location has changed; be sure to"
+ echo " restart any local applications using libpq.so."
+ fi
+}
+
+post_remove() {
+ if getent passwd postgres >/dev/null; then
+ userdel postgres
+ fi
+ if getent group postgres >/dev/null; then
+ groupdel postgres
+ fi
+}
diff --git a/postgresql.logrotate b/postgresql.logrotate
new file mode 100644
index 000000000000..9c36918be5e5
--- /dev/null
+++ b/postgresql.logrotate
@@ -0,0 +1,4 @@
+/var/log/postgresql.log {
+ copytruncate
+ missingok
+}
diff --git a/postgresql.pam b/postgresql.pam
new file mode 100644
index 000000000000..53724d1f86a7
--- /dev/null
+++ b/postgresql.pam
@@ -0,0 +1,3 @@
+auth required pam_unix.so
+account required pam_unix.so
+session required pam_unix.so
diff --git a/postgresql.tmpfiles.conf b/postgresql.tmpfiles.conf
new file mode 100644
index 000000000000..c2e0747dae63
--- /dev/null
+++ b/postgresql.tmpfiles.conf
@@ -0,0 +1 @@
+d /run/postgresql 0775 postgres postgres -