summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2020-02-25 11:29:29 +0100
committerAlexander F. Rødseth2020-02-25 11:29:29 +0100
commitadc4a56ada14f5b9df73fceed627da4761bc8cdb (patch)
treeb72c7d072f1ba067bf09f21645be18d89ffe7cd7
downloadaur-adc4a56ada14f5b9df73fceed627da4761bc8cdb.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98d192aa25ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = aget
+ pkgdesc = Detect which compiler version was used for compiling an ELF file
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/xyproto/aget
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = git+https://github.com/xyproto/aget#tag=1.0.0
+ sha256sums = SKIP
+
+pkgname = aget
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04329e48e224
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=aget
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Detect which compiler version was used for compiling an ELF file'
+arch=(x86_64)
+url='https://github.com/xyproto/aget'
+license=(MIT)
+makedepends=(go git)
+source=("git+https://github.com/xyproto/aget#tag=$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ cd $pkgname
+ go build -mod=vendor -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"
+}
+
+package() {
+ install -Dm755 "$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: