summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlavi Pantaleev2023-03-25 17:04:26 +0200
committerSlavi Pantaleev2023-03-25 17:06:58 +0200
commit9238e3cdb0a50f8551236ebd3153b649e6468f7d (patch)
tree6723862b7e9d439ba3b5ae9d18b1dc65b4672cd8
downloadaur-9238e3cdb0a50f8551236ebd3153b649e6468f7d.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87cb4e4088e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = agru
+ pkgdesc = Ansible-Galaxy Requirements Updater - a fast ansible-galaxy replacement
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://gitlab.com/etke.cc/int/agru
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ source = vcs-repository::git+https://gitlab.com/etke.cc/int/agru.git#tag=v0.1.1
+ md5sums = SKIP
+
+pkgname = agru
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0c955bb3328e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+agru*.pkg.*
+pkg
+src
+vcs-repository
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bade7b325b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Slavi Pantaleev <slavi at devture dot com>
+# To report issues or contribute: https://github.com/spantaleev/PKGBUILDs
+
+pkgname=agru
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Ansible-Galaxy Requirements Updater - a fast ansible-galaxy replacement"
+arch=('any')
+url="https://gitlab.com/etke.cc/int/agru"
+license=('GPL3')
+depends=()
+makedepends=('git' 'go')
+source=('vcs-repository::git+https://gitlab.com/etke.cc/int/agru.git#tag=v'$pkgver)
+md5sums=('SKIP')
+
+build() {
+ export GOPATH="$srcdir/go"
+
+ cd "$srcdir/vcs-repository"
+
+ go build -v -o agru .
+}
+
+package() {
+ install -Dm 755 $srcdir/vcs-repository/agru $pkgdir/usr/bin/agru
+}