summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2016-09-16 14:03:20 -0600
committerAinola2016-09-16 14:03:20 -0600
commit2503e9405be75cfa11a1d6c0ad9655a2f7b6c04f (patch)
tree6000b3b5eba1e4c09840015d89540a1d3f6b593b
parentf294d47d616368ffd9b64df67b0e6f79550c13bd (diff)
downloadaur-2503e9405be75cfa11a1d6c0ad9655a2f7b6c04f.tar.gz
upgpkg: 3.4.0.12, add compilation patch
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
-rw-r--r--fix-cpp-11-mode.patch21
3 files changed, 36 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cad7837a752..ef227c8c1d52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Sep 11 01:20:12 UTC 2016
+# Fri Sep 16 20:03:17 UTC 2016
pkgbase = ags
pkgdesc = A development tool that is primarily used to create graphical adventure games
- pkgver = 3.3.5.11
+ pkgver = 3.4.0.12
pkgrel = 1
url = https://github.com/adventuregamestudio/ags
install = ags.install
@@ -16,9 +16,10 @@ pkgbase = ags
depends = libtheora
depends = libvorbis
optdepends = wine: for installing and configuring the game
- conflicts = ags-git
- source = https://github.com/adventuregamestudio/ags/archive/v.3.3.5.11.tar.gz
- sha256sums = 029e0a4f2c12617a9672eee7cfc7e9c9aba0421bfb18c8a8210bf7fba5f63825
+ source = https://github.com/adventuregamestudio/ags/archive/v.3.4.0.12.tar.gz
+ source = fix-cpp-11-mode.patch
+ sha256sums = 64422a3ad7ed1d78d207158f6d8a67499e6d0b50a9dd6438d086373ac66d1a76
+ sha256sums = 67ba92334c08626cec954edca5e164fdb619d690e518685402632be9ea4348ce
pkgname = ags
diff --git a/PKGBUILD b/PKGBUILD
index 2a9d6f16f70d..6879b3f6d8d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: quantax
pkgname=ags
-pkgver=3.3.5.11
+pkgver=3.4.0.12
pkgrel=1
pkgdesc="A development tool that is primarily used to create graphical adventure games"
arch=('i686' 'x86_64')
@@ -13,10 +13,16 @@ depends=('allegro' 'dumb' 'libogg' 'libtheora' 'libvorbis')
makedepends=('wxgtk')
optdepends=('wine: for installing and configuring the game')
install=ags.install
-source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz")
-sha256sums=('029e0a4f2c12617a9672eee7cfc7e9c9aba0421bfb18c8a8210bf7fba5f63825')
+source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz"
+ "fix-cpp-11-mode.patch")
+sha256sums=('64422a3ad7ed1d78d207158f6d8a67499e6d0b50a9dd6438d086373ac66d1a76'
+ '67ba92334c08626cec954edca5e164fdb619d690e518685402632be9ea4348ce')
prepare() {
+ # Fixes https://github.com/adventuregamestudio/ags/issues/356 until an
+ # official release
+ patch -p1 -d "$srcdir/ags-v.${pkgver}" < fix-cpp-11-mode.patch
+
cd "$srcdir/ags-v.${pkgver}"
sed -i 's/-Wfatal-errors\ //' Engine/Makefile-defs.linux
}
diff --git a/fix-cpp-11-mode.patch b/fix-cpp-11-mode.patch
new file mode 100644
index 000000000000..085f9b6889e7
--- /dev/null
+++ b/fix-cpp-11-mode.patch
@@ -0,0 +1,21 @@
+From 5a8dc7a37b312ea8d308db03bd14a6f5d6583a1f Mon Sep 17 00:00:00 2001
+From: Ivan Mogilko <ikm_spb@yahoo.com>
+Date: Fri, 16 Sep 2016 22:20:28 +0300
+Subject: [PATCH] Engine: fixed compilation in C++11 mode
+
+---
+ Engine/script/cc_instance.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Engine/script/cc_instance.h b/Engine/script/cc_instance.h
+index e2865fb..97a6a83 100644
+--- a/Engine/script/cc_instance.h
++++ b/Engine/script/cc_instance.h
+@@ -20,6 +20,7 @@
+ #define __CC_INSTANCE_H
+
+ #if __cplusplus >= 201103L
++#include <memory>
+ #include <unordered_map>
+ namespace stdtr1compat = std;
+ #else