summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2017-02-06 10:22:49 -0700
committerAinola2017-02-06 10:22:49 -0700
commit4046c157065cea6b940faed31f1d308e6f6a8f71 (patch)
tree932223e77066933867859d1f569ed442830303bb
parent2503e9405be75cfa11a1d6c0ad9655a2f7b6c04f (diff)
downloadaur-4046c157065cea6b940faed31f1d308e6f6a8f71.tar.gz
upgpkg: 3.4.0.14
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--fix-cpp-11-mode.patch21
3 files changed, 7 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef227c8c1d52..bf99389dc384 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Sep 16 20:03:17 UTC 2016
+# Mon Feb 6 17:22:27 UTC 2017
pkgbase = ags
pkgdesc = A development tool that is primarily used to create graphical adventure games
- pkgver = 3.4.0.12
+ pkgver = 3.4.0.14
pkgrel = 1
url = https://github.com/adventuregamestudio/ags
install = ags.install
@@ -16,10 +16,8 @@ pkgbase = ags
depends = libtheora
depends = libvorbis
optdepends = wine: for installing and configuring the game
- source = https://github.com/adventuregamestudio/ags/archive/v.3.4.0.12.tar.gz
- source = fix-cpp-11-mode.patch
- sha256sums = 64422a3ad7ed1d78d207158f6d8a67499e6d0b50a9dd6438d086373ac66d1a76
- sha256sums = 67ba92334c08626cec954edca5e164fdb619d690e518685402632be9ea4348ce
+ source = https://github.com/adventuregamestudio/ags/archive/v.3.4.0.14.tar.gz
+ sha256sums = 8868080c01f84b78bdbae2437cdbda37ef22c5440e7dfcff07603e2aca24b522
pkgname = ags
diff --git a/PKGBUILD b/PKGBUILD
index 6879b3f6d8d4..ee0f807054a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: quantax
pkgname=ags
-pkgver=3.4.0.12
+pkgver=3.4.0.14
pkgrel=1
pkgdesc="A development tool that is primarily used to create graphical adventure games"
arch=('i686' 'x86_64')
@@ -13,16 +13,10 @@ depends=('allegro' 'dumb' 'libogg' 'libtheora' 'libvorbis')
makedepends=('wxgtk')
optdepends=('wine: for installing and configuring the game')
install=ags.install
-source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz"
- "fix-cpp-11-mode.patch")
-sha256sums=('64422a3ad7ed1d78d207158f6d8a67499e6d0b50a9dd6438d086373ac66d1a76'
- '67ba92334c08626cec954edca5e164fdb619d690e518685402632be9ea4348ce')
+source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz")
+sha256sums=('8868080c01f84b78bdbae2437cdbda37ef22c5440e7dfcff07603e2aca24b522')
prepare() {
- # Fixes https://github.com/adventuregamestudio/ags/issues/356 until an
- # official release
- patch -p1 -d "$srcdir/ags-v.${pkgver}" < fix-cpp-11-mode.patch
-
cd "$srcdir/ags-v.${pkgver}"
sed -i 's/-Wfatal-errors\ //' Engine/Makefile-defs.linux
}
diff --git a/fix-cpp-11-mode.patch b/fix-cpp-11-mode.patch
deleted file mode 100644
index 085f9b6889e7..000000000000
--- a/fix-cpp-11-mode.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 5a8dc7a37b312ea8d308db03bd14a6f5d6583a1f Mon Sep 17 00:00:00 2001
-From: Ivan Mogilko <ikm_spb@yahoo.com>
-Date: Fri, 16 Sep 2016 22:20:28 +0300
-Subject: [PATCH] Engine: fixed compilation in C++11 mode
-
----
- Engine/script/cc_instance.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/Engine/script/cc_instance.h b/Engine/script/cc_instance.h
-index e2865fb..97a6a83 100644
---- a/Engine/script/cc_instance.h
-+++ b/Engine/script/cc_instance.h
-@@ -20,6 +20,7 @@
- #define __CC_INSTANCE_H
-
- #if __cplusplus >= 201103L
-+#include <memory>
- #include <unordered_map>
- namespace stdtr1compat = std;
- #else