summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2016-06-17 00:04:19 -0600
committerAinola2016-06-17 00:04:19 -0600
commite24a00bcb927f8354122876f028e8317a716fbe8 (patch)
tree7a30ae96b236f8afa8ad9dd448038b5832a1ac8b
parent50c8e46ce8cf3e55c60821dd1ebaffbe3435c5f7 (diff)
downloadaur-e24a00bcb927f8354122876f028e8317a716fbe8.tar.gz
upgpkg: 3.3.5.7
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--fix-namespaces.patch120
3 files changed, 6 insertions, 126 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e924151de1e8..99b303863f11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jun 4 13:27:19 UTC 2016
+# Fri Jun 17 06:03:56 UTC 2016
pkgbase = ags
pkgdesc = A development tool that is primarily used to create graphical adventure games
- pkgver = 3.3.5.6
+ pkgver = 3.3.5.7
pkgrel = 3
url = https://github.com/adventuregamestudio/ags
install = ags.install
@@ -17,8 +17,8 @@ pkgbase = ags
depends = libvorbis
optdepends = wine: for installing and configuring the game
conflicts = ags-git
- source = https://github.com/adventuregamestudio/ags/archive/v.3.3.5.6.tar.gz
- sha256sums = 3496f35b9799cff2e626a4049a6bd28145191fc9469c45b84d0cc04178963c34
+ source = https://github.com/adventuregamestudio/ags/archive/v.3.3.5.7.tar.gz
+ sha256sums = 0ba36712fc4a92f02401c307574ed964b9ac19ed06c95fa98fb6af4e9b199df4
pkgname = ags
diff --git a/PKGBUILD b/PKGBUILD
index 23a62618134d..646c5bc587b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: quantax
pkgname=ags
-pkgver=3.3.5.6
+pkgver=3.3.5.7
pkgrel=3
pkgdesc="A development tool that is primarily used to create graphical adventure games"
arch=('i686' 'x86_64')
@@ -15,7 +15,7 @@ optdepends=('wine: for installing and configuring the game')
conflicts=('ags-git')
install=ags.install
source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz")
-sha256sums=('3496f35b9799cff2e626a4049a6bd28145191fc9469c45b84d0cc04178963c34')
+sha256sums=('0ba36712fc4a92f02401c307574ed964b9ac19ed06c95fa98fb6af4e9b199df4')
prepare() {
cd "$srcdir/ags-v.${pkgver}"
diff --git a/fix-namespaces.patch b/fix-namespaces.patch
deleted file mode 100644
index 02771aa487fa..000000000000
--- a/fix-namespaces.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-From 1ef4a705f32ff0774585ee1e0209a74e8332b782 Mon Sep 17 00:00:00 2001
-From: Ivan Mogilko <ikm_spb@yahoo.com>
-Date: Mon, 23 May 2016 20:28:37 +0300
-Subject: [PATCH] Plugins: moved standard library header includes out of plugin
- namespace
-
----
- Plugins/AGSflashlight/agsflashlight.cpp | 14 +++++++-------
- Plugins/ags_parallax/ags_parallax.cpp | 12 ++++++------
- Plugins/ags_snowrain/ags_snowrain.cpp | 14 +++++++-------
- 3 files changed, 20 insertions(+), 20 deletions(-)
-
-diff --git a/Plugins/AGSflashlight/agsflashlight.cpp b/Plugins/AGSflashlight/agsflashlight.cpp
-index 30aa54f..687cb54 100644
---- a/Plugins/AGSflashlight/agsflashlight.cpp
-+++ b/Plugins/AGSflashlight/agsflashlight.cpp
-@@ -16,12 +16,6 @@ but a workalike plugin created by JJS for the AGS engine PSP port.
- #define THIS_IS_THE_PLUGIN
- #endif
-
--#include "plugin/agsplugin.h"
--
--#if defined(BUILTIN_PLUGINS)
--namespace agsflashlight {
--#endif
--
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
-@@ -34,6 +28,12 @@ namespace agsflashlight {
- #define sin(x) vfpu_sinf(x)
- #endif
-
-+#include "plugin/agsplugin.h"
-+
-+#if defined(BUILTIN_PLUGINS)
-+namespace agsflashlight {
-+#endif
-+
- #if defined(__GNUC__)
- inline unsigned long _blender_alpha16_bgr(unsigned long y) __attribute__((always_inline));
- inline void calc_x_n(unsigned long bla) __attribute__((always_inline));
-@@ -946,5 +946,5 @@ void AGS_EditorLoadGame(char* buffer, int bufsize)
-
-
- #if defined(BUILTIN_PLUGINS)
--}
-+} // namespace agsflashlight
- #endif
-diff --git a/Plugins/ags_parallax/ags_parallax.cpp b/Plugins/ags_parallax/ags_parallax.cpp
-index c9203d5..60fac06 100644
---- a/Plugins/ags_parallax/ags_parallax.cpp
-+++ b/Plugins/ags_parallax/ags_parallax.cpp
-@@ -16,17 +16,17 @@ but a workalike plugin created by JJS for the AGS engine ports.
- #define THIS_IS_THE_PLUGIN
- #endif
-
-+#include <stdlib.h>
-+#include <stdio.h>
-+#include <string.h>
-+#include <math.h>
-+
- #include "plugin/agsplugin.h"
-
- #if defined(BUILTIN_PLUGINS)
- namespace ags_parallax {
- #endif
-
--#include <stdlib.h>
--#include <stdio.h>
--#include <string.h>
--#include <math.h>
--
- //#define DEBUG
- //#define ENABLE_SAVING // The original plugin does not save any data!
-
-@@ -343,5 +343,5 @@ void AGS_EditorLoadGame(char* buffer, int bufsize)
-
-
- #if defined(BUILTIN_PLUGINS)
--}
-+} // namespace ags_parallax
- #endif
-diff --git a/Plugins/ags_snowrain/ags_snowrain.cpp b/Plugins/ags_snowrain/ags_snowrain.cpp
-index 39102d6..14e858a 100644
---- a/Plugins/ags_snowrain/ags_snowrain.cpp
-+++ b/Plugins/ags_snowrain/ags_snowrain.cpp
-@@ -16,12 +16,6 @@ but a workalike plugin created by JJS for the AGS engine PSP port.
- #define THIS_IS_THE_PLUGIN
- #endif
-
--#include "plugin/agsplugin.h"
--
--#if defined(BUILTIN_PLUGINS)
--namespace ags_snowrain {
--#endif
--
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
-@@ -33,6 +27,12 @@ namespace ags_snowrain {
- #define sin(x) vfpu_sinf(x)
- #endif
-
-+#include "plugin/agsplugin.h"
-+
-+#if defined(BUILTIN_PLUGINS)
-+namespace ags_snowrain {
-+#endif
-+
- //#define DEBUG
- //#define AGS_SNOWRAIN_DLL_SAVEGAME_COMPATIBILITY
-
-@@ -960,5 +960,5 @@ void AGS_EditorLoadGame(char* buffer, int bufsize)
-
-
- #if defined(BUILTIN_PLUGINS)
--}
-+} // namespace ags_snowrain
- #endif