summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-08-25 12:28:00 -0600
committerAinola2018-08-25 12:28:00 -0600
commite8c859636f1617bec943fa2a21684e1bf0957d75 (patch)
tree1d2b08f10296dc749044593925e7bb7b88404073
parent84ec1ef8638ec9e6e56c5e5c8fb126099f2cad5f (diff)
downloadaur-e8c859636f1617bec943fa2a21684e1bf0957d75.tar.gz
upgpkg: 3.4.1.14, add functions conflict patch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a51b4ae9a5f..d8cb650f067c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Dec 12 02:48:29 UTC 2017
+# Sat Aug 25 18:27:36 UTC 2018
pkgbase = ags
pkgdesc = A development tool that is primarily used to create graphical adventure games
- pkgver = 3.4.1.10
+ pkgver = 3.4.1.14
pkgrel = 1
url = https://github.com/adventuregamestudio/ags
arch = i686
@@ -15,8 +15,10 @@ pkgbase = ags
depends = libtheora
depends = libvorbis
optdepends = wine: for installing and configuring the game
- source = https://github.com/adventuregamestudio/ags/archive/v.3.4.1.10.tar.gz
- sha256sums = 7dd75df2131333f1b6885c89db275e0dee3f7b55d3d9c4e8afae612c94aca4e2
+ source = https://github.com/adventuregamestudio/ags/archive/v.3.4.1.14.tar.gz
+ source = https://github.com/adventuregamestudio/ags/commit/44d954493bb5f3e95a11a4eddbb62bd6110b1b63.patch
+ sha256sums = 4ca76b919689c68a9fda4bd56bfb63268ab5326a539ce4d681ac4ed6a908b51c
+ sha256sums = 6b7092e5794ae532f79c5c6ad5f5761c217b3ec874da43537152fb8e60b20019
pkgname = ags
diff --git a/PKGBUILD b/PKGBUILD
index b743465c8f0c..2c0503dac259 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: xyproto
pkgname=ags
-pkgver=3.4.1.10
+pkgver=3.4.1.14
pkgrel=1
pkgdesc='A development tool that is primarily used to create graphical adventure games'
arch=('i686' 'x86_64')
@@ -13,14 +13,20 @@ license=('Artistic2.0')
depends=('allegro4' 'dumb-a4' 'libogg' 'libtheora' 'libvorbis')
makedepends=('wxgtk')
optdepends=('wine: for installing and configuring the game')
-source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz")
-sha256sums=('7dd75df2131333f1b6885c89db275e0dee3f7b55d3d9c4e8afae612c94aca4e2')
+source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz"
+ 'https://github.com/adventuregamestudio/ags/commit/44d954493bb5f3e95a11a4eddbb62bd6110b1b63.patch')
+sha256sums=('4ca76b919689c68a9fda4bd56bfb63268ab5326a539ce4d681ac4ed6a908b51c'
+ '6b7092e5794ae532f79c5c6ad5f5761c217b3ec874da43537152fb8e60b20019')
prepare() {
# Copious use of auto_ptr spams the compilation output. Until they're
# replaced, just suppress the message.
sed -i 's/-Wfatal-errors/-Wfatal-errors\ -Wno-deprecated-declarations/' \
"ags-v.$pkgver/Engine/Makefile-defs.linux"
+
+ # avoid conflicts with glibc functions with the same names
+ cd "$srcdir/ags-v.${pkgver}"
+ patch -p1 < ../44d954493bb5f3e95a11a4eddbb62bd6110b1b63.patch
}
build() {