summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2016-05-24 21:45:05 -0600
committerAinola2016-05-24 21:45:05 -0600
commitfc298112f8995feb7a91cb0dfd1aa805b81c4f51 (patch)
treed8d965421d7f577b4d6f57d56a3a3e64f5cba7f3
parentcc38ab3d2cc8c8e4e0c8b9d3469f36a33e7fc2cf (diff)
downloadaur-fc298112f8995feb7a91cb0dfd1aa805b81c4f51.tar.gz
fix compilation errors on GCC 6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--fix-namespaces.patch120
3 files changed, 131 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2385d1afa6fd..5d91c04a462a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun May 8 01:34:37 UTC 2016
+# Wed May 25 03:44:52 UTC 2016
pkgbase = ags
pkgdesc = A development tool that is primarily used to create graphical adventure games
pkgver = 3.3.5.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/adventuregamestudio/ags
install = ags.install
arch = i686
@@ -18,7 +18,9 @@ pkgbase = ags
optdepends = wine: for installing and configuring the game
conflicts = ags-git
source = https://github.com/adventuregamestudio/ags/archive/v.3.3.5.5.tar.gz
+ source = fix-namespaces.patch
sha256sums = f2b31a3d5152fd50d6a9fae1e019dcf3d0823f5968d5fbe344478c524afa7d9f
+ sha256sums = 9d715eb5a269b66465361d6723f9b58bd6c0607cb25af0d19286e4021bc8957a
pkgname = ags
diff --git a/PKGBUILD b/PKGBUILD
index a0e3b7225ee8..01e139274ad3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=ags
pkgver=3.3.5.5
-pkgrel=2
+pkgrel=3
pkgdesc="A development tool that is primarily used to create graphical adventure games"
arch=('i686' 'x86_64')
url="https://github.com/adventuregamestudio/ags"
@@ -14,16 +14,17 @@ makedepends=('wxgtk')
optdepends=('wine: for installing and configuring the game')
conflicts=('ags-git')
install=ags.install
-source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz")
-sha256sums=('f2b31a3d5152fd50d6a9fae1e019dcf3d0823f5968d5fbe344478c524afa7d9f')
+source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz"
+ "fix-namespaces.patch")
+sha256sums=('f2b31a3d5152fd50d6a9fae1e019dcf3d0823f5968d5fbe344478c524afa7d9f'
+ '9d715eb5a269b66465361d6723f9b58bd6c0607cb25af0d19286e4021bc8957a')
prepare() {
cd "$srcdir/ags-v.${pkgver}"
sed -i 's/-Wfatal-errors\ //' Engine/Makefile-defs.linux
- # Can be removed onnext release
- # (see https://github.com/adventuregamestudio/ags/issues/327)
- sed -i 's/-ldumb/-ldumb -lm/' Engine/Makefile-defs.linux
+ # https://github.com/adventuregamestudio/ags/issues/328
+ patch -p1 < ../fix-namespaces.patch
}
build() {
diff --git a/fix-namespaces.patch b/fix-namespaces.patch
new file mode 100644
index 000000000000..02771aa487fa
--- /dev/null
+++ b/fix-namespaces.patch
@@ -0,0 +1,120 @@
+From 1ef4a705f32ff0774585ee1e0209a74e8332b782 Mon Sep 17 00:00:00 2001
+From: Ivan Mogilko <ikm_spb@yahoo.com>
+Date: Mon, 23 May 2016 20:28:37 +0300
+Subject: [PATCH] Plugins: moved standard library header includes out of plugin
+ namespace
+
+---
+ Plugins/AGSflashlight/agsflashlight.cpp | 14 +++++++-------
+ Plugins/ags_parallax/ags_parallax.cpp | 12 ++++++------
+ Plugins/ags_snowrain/ags_snowrain.cpp | 14 +++++++-------
+ 3 files changed, 20 insertions(+), 20 deletions(-)
+
+diff --git a/Plugins/AGSflashlight/agsflashlight.cpp b/Plugins/AGSflashlight/agsflashlight.cpp
+index 30aa54f..687cb54 100644
+--- a/Plugins/AGSflashlight/agsflashlight.cpp
++++ b/Plugins/AGSflashlight/agsflashlight.cpp
+@@ -16,12 +16,6 @@ but a workalike plugin created by JJS for the AGS engine PSP port.
+ #define THIS_IS_THE_PLUGIN
+ #endif
+
+-#include "plugin/agsplugin.h"
+-
+-#if defined(BUILTIN_PLUGINS)
+-namespace agsflashlight {
+-#endif
+-
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -34,6 +28,12 @@ namespace agsflashlight {
+ #define sin(x) vfpu_sinf(x)
+ #endif
+
++#include "plugin/agsplugin.h"
++
++#if defined(BUILTIN_PLUGINS)
++namespace agsflashlight {
++#endif
++
+ #if defined(__GNUC__)
+ inline unsigned long _blender_alpha16_bgr(unsigned long y) __attribute__((always_inline));
+ inline void calc_x_n(unsigned long bla) __attribute__((always_inline));
+@@ -946,5 +946,5 @@ void AGS_EditorLoadGame(char* buffer, int bufsize)
+
+
+ #if defined(BUILTIN_PLUGINS)
+-}
++} // namespace agsflashlight
+ #endif
+diff --git a/Plugins/ags_parallax/ags_parallax.cpp b/Plugins/ags_parallax/ags_parallax.cpp
+index c9203d5..60fac06 100644
+--- a/Plugins/ags_parallax/ags_parallax.cpp
++++ b/Plugins/ags_parallax/ags_parallax.cpp
+@@ -16,17 +16,17 @@ but a workalike plugin created by JJS for the AGS engine ports.
+ #define THIS_IS_THE_PLUGIN
+ #endif
+
++#include <stdlib.h>
++#include <stdio.h>
++#include <string.h>
++#include <math.h>
++
+ #include "plugin/agsplugin.h"
+
+ #if defined(BUILTIN_PLUGINS)
+ namespace ags_parallax {
+ #endif
+
+-#include <stdlib.h>
+-#include <stdio.h>
+-#include <string.h>
+-#include <math.h>
+-
+ //#define DEBUG
+ //#define ENABLE_SAVING // The original plugin does not save any data!
+
+@@ -343,5 +343,5 @@ void AGS_EditorLoadGame(char* buffer, int bufsize)
+
+
+ #if defined(BUILTIN_PLUGINS)
+-}
++} // namespace ags_parallax
+ #endif
+diff --git a/Plugins/ags_snowrain/ags_snowrain.cpp b/Plugins/ags_snowrain/ags_snowrain.cpp
+index 39102d6..14e858a 100644
+--- a/Plugins/ags_snowrain/ags_snowrain.cpp
++++ b/Plugins/ags_snowrain/ags_snowrain.cpp
+@@ -16,12 +16,6 @@ but a workalike plugin created by JJS for the AGS engine PSP port.
+ #define THIS_IS_THE_PLUGIN
+ #endif
+
+-#include "plugin/agsplugin.h"
+-
+-#if defined(BUILTIN_PLUGINS)
+-namespace ags_snowrain {
+-#endif
+-
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -33,6 +27,12 @@ namespace ags_snowrain {
+ #define sin(x) vfpu_sinf(x)
+ #endif
+
++#include "plugin/agsplugin.h"
++
++#if defined(BUILTIN_PLUGINS)
++namespace ags_snowrain {
++#endif
++
+ //#define DEBUG
+ //#define AGS_SNOWRAIN_DLL_SAVEGAME_COMPATIBILITY
+
+@@ -960,5 +960,5 @@ void AGS_EditorLoadGame(char* buffer, int bufsize)
+
+
+ #if defined(BUILTIN_PLUGINS)
+-}
++} // namespace ags_snowrain
+ #endif