summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-04-24 10:20:54 -0500
committerDan Beste2017-04-24 10:20:54 -0500
commit62fdd8c95884d019049f1d384fd05486e03808c8 (patch)
treedd864c1daf3af3df32de27afb436641aa35c7508
parentc1882dafe849539d2bd47792f4a1327c9ac306d8 (diff)
downloadaur-62fdd8c95884d019049f1d384fd05486e03808c8.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD64
2 files changed, 24 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f68fc6f2f5c5..83766316b7ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ags-git
pkgdesc = Adventure Game Studio, a development tool that is primarily used to create graphical adventure games
- pkgver = 3.4.1.1.r13.g6053e954
+ pkgver = 3.4.1.3.r7.gb4199b73
pkgrel = 1
url = http://www.adventuregamestudio.co.uk/
arch = i686
@@ -13,6 +13,7 @@ pkgbase = ags-git
depends = libtheora
depends = libvorbis
optdepends = wine: For non-native games
+ provides = ags
conflicts = ags
source = git+https://github.com/adventuregamestudio/ags.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 51d4f34e0a8f..918970a471ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,29 @@
# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
+# Previously:
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+
# Contributor: Ainola
# Contributor: Ner0
# Contributor: quantax
-# Previously:
-# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
-
pkgname='ags-git'
_pkgname='ags'
-pkgver=3.4.1.1.r13.g6053e954
+pkgver=3.4.1.3.r7.gb4199b73
pkgrel=1
pkgdesc="Adventure Game Studio, a development tool that is primarily used to create graphical adventure games"
-arch=(
- 'i686'
- 'x86_64'
-)
+arch=('i686' 'x86_64')
url='http://www.adventuregamestudio.co.uk/'
-license=(
- 'custom: Artistic 2.0'
-)
-depends=(
- 'allegro'
- 'dumb'
- 'libogg'
- 'libtheora'
- 'libvorbis'
-)
-makedepends=(
- 'git'
-)
-optdepends=(
- 'wine: For non-native games'
-)
-conflicts=(
- 'ags'
-)
-source=(
- 'git+https://github.com/adventuregamestudio/ags.git'
-)
-sha256sums=(
- 'SKIP'
-)
+license=('custom: Artistic 2.0')
+depends=('allegro' 'dumb' 'libogg' 'libtheora' 'libvorbis')
+makedepends=('git')
+optdepends=('wine: For non-native games')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=('git+https://github.com/adventuregamestudio/ags.git')
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}" || exit 1
+ cd "${_pkgname}"
git describe --long --tags \
| sed 's/\([^-]*-g\)/r\1/;s/-/./g' \
@@ -51,19 +31,19 @@ pkgver() {
}
build() {
- cd "${srcdir}/${_pkgname}" || exit 1
+ cd "${_pkgname}"
make --directory=Engine
}
package() {
- install -Dm755 \
- "${srcdir}/${_pkgname}/Engine/${_pkgname}" \
+ cd "${_pkgname}"
+
+ install -Dm 755 \
+ "Engine/${_pkgname}" \
"${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 \
- "${srcdir}/${_pkgname}/License.txt" \
- "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 \
+ "License.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-