summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-02-18 21:59:43 -0600
committerDan Beste2017-02-18 21:59:43 -0600
commit9bde3121055c2d1e07cb049988b709e2b960b25f (patch)
treee9b6d351d99ebdb04e0786b862621ffc6da5e99e
parentd70d53821a3c3246ca9f199a1ab824f0a9715c8f (diff)
downloadaur-9bde3121055c2d1e07cb049988b709e2b960b25f.tar.gz
Clean PKGBUILD
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD77
-rw-r--r--ags.install11
4 files changed, 64 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 868b83949e98..5c17b5d81497 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,21 @@
-# Generated by mksrcinfo v8
-# Mon Apr 4 09:47:58 UTC 2016
pkgbase = ags-git
pkgdesc = Adventure Game Studio, a development tool that is primarily used to create graphical adventure games
- pkgver = v.3.3.5.4.r0.g1ea2d33
+ pkgver = 3.4.1.1.r13.g6053e954
pkgrel = 1
- url = https://github.com/adventuregamestudio/ags
- install = ags.install
+ url = http://www.adventuregamestudio.co.uk/
arch = i686
arch = x86_64
- license = Artistic2.0
+ license = custom: Artistic 2.0
makedepends = git
- makedepends = wxgtk
depends = allegro
depends = dumb
depends = libogg
depends = libtheora
depends = libvorbis
- optdepends = wine: for installing and configuring the game
+ optdepends = wine: For non-native games
conflicts = ags
source = git://github.com/adventuregamestudio/ags.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = ags-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9865d22ba8ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Blacklist:
+*
+
+# Whitelist:
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 4b8d4da1ac2c..0d75b7230d36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,69 @@
-# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
# Contributor: Ainola
# Contributor: Ner0
# Contributor: quantax
-pkgname=ags-git
-pkgver=v.3.3.5.4.r0.g1ea2d33
+# Previously:
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+
+pkgname='ags-git'
+_pkgname='ags'
+pkgver=3.4.1.1.r13.g6053e954
pkgrel=1
pkgdesc="Adventure Game Studio, a development tool that is primarily used to create graphical adventure games"
-arch=('i686' 'x86_64')
-url="https://github.com/adventuregamestudio/ags"
-license=('Artistic2.0')
-depends=('allegro' 'dumb' 'libogg' 'libtheora' 'libvorbis')
-makedepends=('git' 'wxgtk')
-optdepends=('wine: for installing and configuring the game')
-conflicts=('ags')
-install=ags.install
-source=('git://github.com/adventuregamestudio/ags.git')
-md5sums=('SKIP')
+arch=(
+ 'i686'
+ 'x86_64'
+)
+url='http://www.adventuregamestudio.co.uk/'
+license=(
+ 'custom: Artistic 2.0'
+)
+depends=(
+ 'allegro'
+ 'dumb'
+ 'libogg'
+ 'libtheora'
+ 'libvorbis'
+)
+makedepends=(
+ 'git'
+)
+optdepends=(
+ 'wine: For non-native games'
+)
+conflicts=(
+ 'ags'
+)
+source=(
+ 'git://github.com/adventuregamestudio/ags.git'
+)
+sha256sums=(
+ 'SKIP'
+)
pkgver() {
- cd "$srcdir/ags"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
+ cd "${srcdir}/${_pkgname}" || exit 1
-#prepare() {
-# cd "$srcdir/ags"
-# sed -i 's/-Wfatal-errors\ //' Engine/Makefile-defs.linux
-# git submodule update --init
-#}
+ git describe --long --tags \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g' \
+ | sed 's/v.//'
+}
build() {
- cd "$srcdir/ags"
- make -C Engine
+ cd "${srcdir}/${_pkgname}" || exit 1
+
+ make --directory=Engine
}
package() {
- install -Dm755 "$srcdir/ags/Engine/ags" "$pkgdir/usr/bin/ags"
- install -Dm644 "$srcdir/ags/License.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 \
+ "${srcdir}/${_pkgname}/Engine/${_pkgname}" \
+ "${pkgdir}/usr/bin/${_pkgname}"
+
+ install -Dm644 \
+ "${srcdir}/${_pkgname}/License.txt" \
+ "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/ags.install b/ags.install
deleted file mode 100644
index 62403a86f514..000000000000
--- a/ags.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- echo ""
- echo " In order to run a game, you must first install it either with Wine"
- echo " or just use Windows installation"
-
- echo " To run it type ags '/GameDir/Game.exe'"
-
- echo " The native game configurator isn't supported yet,"
- echo " so you must use the Windows one ('winsetup.exe') with Wine."
- echo ""
-}