summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Quirk2015-06-13 08:53:00 +0200
committerRichard Quirk2015-06-13 08:53:00 +0200
commit2f8bc5d5a1d8b5f338d1bef9468f012a40135220 (patch)
treee5d9db4007733bca993b6f413d2c2524616e7c56
downloadaur-2f8bc5d5a1d8b5f338d1bef9468f012a40135220.tar.gz
Import from aur
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..462d17b242ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Sat Jun 13 06:51:12 UTC 2015
+pkgbase = aha
+ pkgdesc = Ansi HTML Adapter: convert ANSI escape sequences to HTML.
+ pkgver = 0.4.8
+ pkgrel = 1
+ url = https://github.com/theZiz/aha
+ arch = i686
+ arch = x86_64
+ license = MPL
+ license = LPGL
+ provides = aha
+ conflicts = aha
+ source = https://github.com/theZiz/aha/archive/0.4.8.tar.gz
+ sha512sums = 8d66ee7ec6d59873c1f0bedbc4deecd0c7b84c18069d2181d7b0563d9600821455c62c37c0af1774c7190ce08b14ec52f10bdf2c15a97fd29a2b6b095d5924fa
+
+pkgname = aha
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33e63c54f5df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=aha
+pkgver=0.4.8
+pkgrel=1
+pkgdesc="Ansi HTML Adapter: convert ANSI escape sequences to HTML."
+arch=('i686' 'x86_64')
+url="https://github.com/theZiz/aha"
+license=('MPL' 'LPGL')
+provides=('aha')
+conflicts=('aha')
+
+source=("$url/archive/${pkgver}.tar.gz")
+sha512sums=('8d66ee7ec6d59873c1f0bedbc4deecd0c7b84c18069d2181d7b0563d9600821455c62c37c0af1774c7190ce08b14ec52f10bdf2c15a97fd29a2b6b095d5924fa')
+
+build() {
+ cd -- "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd -- "$srcdir/$pkgname-$pkgver"
+ install -Dm755 "aha" "$pkgdir/usr/bin/aha"
+ install -Dm644 "aha.1" "$pkgdir/usr/share/man/man1/aha.1"
+}
+
+# vim:set ts=2 sw=2 et: