summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXyne2015-06-21 02:44:28 +0000
committerXyne2015-06-21 02:44:28 +0000
commitf6d7ce57f6e52b8175be26ccda0332b368e4f1aa (patch)
tree817477100d9e0522bcaca3ded8484cb37c02e9d2
downloadaur-f6d7ce57f6e52b8175be26ccda0332b368e4f1aa.tar.gz
Initial import.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4729d1f9086
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = aha-git
+ pkgdesc = Ansi HTML Adapter: convert ANSI escape sequences to HTML.
+ pkgver = 0.4.6.1
+ pkgrel = 2
+ url = http://ziz.delphigl.com/tool_aha.php
+ arch = i686
+ arch = x86_64
+ license = MPL
+ license = LPGL
+ makedepends = git
+ provides = aha
+ conflicts = aha
+ source = git://github.com/theZiz/aha.git#branch=master
+ sha512sums = SKIP
+
+pkgname = aha-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b8539a4902d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+_pkgname=aha
+pkgname=aha-git
+pkgver=0.4.6.1
+pkgrel=2
+pkgdesc="Ansi HTML Adapter: convert ANSI escape sequences to HTML."
+arch=('i686' 'x86_64')
+makedepends=('git')
+#url="https://github.com/theZiz/aha"
+url="http://ziz.delphigl.com/tool_aha.php"
+license=('MPL' 'LPGL')
+provides=('aha')
+conflicts=('aha')
+
+source=('git://github.com/theZiz/aha.git#branch=master')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd -- "$srcdir/$_pkgname"
+# git log -n1 --pretty=format:%ct
+ git describe --tags
+}
+
+build() {
+ cd -- "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd -- "$srcdir/$_pkgname"
+ install -Dm755 "aha" "$pkgdir/usr/bin/aha"
+ install -Dm644 "aha.1" "$pkgdir/usr/share/man/man1/aha.1"
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file