summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraaron2022-02-13 16:41:19 +0800
committeraaron2022-02-13 16:41:19 +0800
commit18a3ed1fc846ca863bf15b3628fd685774958144 (patch)
treea1994d60b48c6ba36e9cb138d695d574cd3b6d27
downloadaur-18a3ed1fc846ca863bf15b3628fd685774958144.tar.gz
useful commit message
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29de5f4ae719
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ahdumb-st
+ pkgdesc = st is a simple terminal implementation for X.
+ pkgver = 0.8.5
+ pkgrel = 4
+ url = https://github.com/AhDumb/st.git
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ source = git+https://github.com/AhDumb/st.git
+ md5sums = SKIP
+
+pkgname = ahdumb-st
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71e8960ecfb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Aaron <wzj020109@163.com>
+_pkgname=st
+pkgname=ahdumb-$_pkgname
+pkgver=0.8.5
+pkgrel=4
+pkgdesc="st is a simple terminal implementation for X."
+arch=("x86_64")
+url="https://github.com/AhDumb/st.git"
+license=('MIT')
+makedepends=('git')
+source=("git+https://github.com/AhDumb/st.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ sudo make install
+}