summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2016-06-05 11:52:36 +1000
committerRod Kay2016-06-05 11:52:36 +1000
commit2d5d2eae41a08cb745021301ed2cc63e4937ca98 (patch)
treecf2f5cbbbbf30504cd7f4a6c80c85528294440e8
parentd3731658d71f3281ac60a6bb0b8bc203398f235d (diff)
downloadaur-2d5d2eae41a08cb745021301ed2cc63e4937ca98.tar.gz
Update to version '2.6'.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--ahven-runner.adb-patch12
-rw-r--r--ahven-text_runner.adb-patch12
4 files changed, 9 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36cc304873e3..4a2cc2308f1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Jun 5 01:50:51 UTC 2016
pkgbase = ahven
pkgdesc = Ahven is a simple unit test framework for the Ada programming language.
- pkgver = 2.4
+ pkgver = 2.6
pkgrel = 1
url = http://ahven.stronglytyped.org/
arch = i686
@@ -8,12 +10,8 @@ pkgbase = ahven
license = BSD
makedepends = sphinxcontrib-adadomain
depends = gcc-ada
- source = http://downloads.sourceforge.net/project/ahven/ahven/Ahven%202.4/ahven-2.4.tar.gz
- source = ahven-text_runner.adb-patch
- source = ahven-runner.adb-patch
- md5sums = f0113f49e36f9f2b33e3682bbfd87e28
- md5sums = 57f341908ec1d8235051cd59b30e4a71
- md5sums = 6d8e78c3757a220f4f8575a4a836e949
+ source = http://www.ahven-framework.com/releases/ahven-2.6.tar.gz
+ md5sums = 776d3da3cd30a9c8d7db1f84f55c8381
pkgname = ahven
diff --git a/PKGBUILD b/PKGBUILD
index 22323a29f378..1c4ac247957b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
pkgname=ahven
-pkgver=2.4
+pkgver=2.6
pkgrel=1
pkgdesc="Ahven is a simple unit test framework for the Ada programming language."
@@ -14,21 +14,12 @@ depends=('gcc-ada')
makedepends=('sphinxcontrib-adadomain')
-source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname/Ahven%20$pkgver/$pkgname-$pkgver.tar.gz
- ahven-text_runner.adb-patch
- ahven-runner.adb-patch)
-
-md5sums=('f0113f49e36f9f2b33e3682bbfd87e28'
- '57f341908ec1d8235051cd59b30e4a71'
- '6d8e78c3757a220f4f8575a4a836e949')
+source=(http://www.ahven-framework.com/releases/ahven-2.6.tar.gz)
+md5sums=('776d3da3cd30a9c8d7db1f84f55c8381')
build() {
cd "$srcdir/$pkgname-$pkgver"
-
- patch -p0 -i ../ahven-text_runner.adb-patch
- patch -p0 -i ../ahven-runner.adb-patch
-
make
}
@@ -41,5 +32,5 @@ check() {
package() {
cd "$srcdir/$pkgname-$pkgver"
- make PREFIX="$pkgdir/usr" SPHINXBUILD=sphinx-build2 install
+ make DESTDIR=$pkgdir PREFIX="$pkgdir/usr" SPHINXBUILD=sphinx-build2 install
}
diff --git a/ahven-runner.adb-patch b/ahven-runner.adb-patch
deleted file mode 100644
index 71ec7540cf49..000000000000
--- a/ahven-runner.adb-patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/ahven-runner.adb-orig
-+++ src/ahven-runner.adb
-@@ -48,7 +48,8 @@
-
- Reporter (Listener.Main_Result, Params);
- if (Error_Count (Listener.Main_Result) > 0) or
-- (Failure_Count (Listener.Main_Result) > 0) then
-+ (Failure_Count (Listener.Main_Result) > 0)
-+ then
- Ada.Command_Line.Set_Exit_Status (Ada.Command_Line.Failure);
- end if;
- exception
diff --git a/ahven-text_runner.adb-patch b/ahven-text_runner.adb-patch
deleted file mode 100644
index 7778a4aea671..000000000000
--- a/ahven-text_runner.adb-patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/ahven-text_runner.adb-orig
-+++ src/ahven-text_runner.adb
-@@ -182,7 +182,8 @@
- exit Test_Loop when not Is_Valid (Position);
- Print_Test (Data (Position), Level, Status);
- if Print_Log and
-- (Length (Get_Output_File (Data (Position))) > 0) then
-+ (Length (Get_Output_File (Data (Position))) > 0)
-+ then
- Print_Log_File (To_String (Get_Output_File (Data (Position))));
- end if;
- Position := Next (Position);